summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2020-03-02 10:15:04 +0000
committerOmar Pakker2020-03-02 10:15:04 +0000
commit7c8784776f0eab28618de9269e059454be53c890 (patch)
tree00426ee16edcfc460a0dd257b8a9b9a6520b47f4
parenta8a00720e703615b60cf527a97d614f94e919875 (diff)
downloadaur-7c8784776f0eab28618de9269e059454be53c890.tar.gz
Add patch to be able to build with latest binutils
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 369a07eddda1..4832cff396e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = looking-glass
pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
pkgver = B1
- pkgrel = 1
+ pkgrel = 2
epoch = 2
url = https://looking-glass.hostfission.com
arch = x86_64
@@ -12,7 +12,9 @@ pkgbase = looking-glass
makedepends = fontconfig
makedepends = spice-protocol
source = https://github.com/gnif/LookingGlass/archive/B1.tar.gz
+ source = https://github.com/gnif/LookingGlass/pull/241.diff
sha512sums = add82702d7e7f601a07db5b9e0de7a7472d3051a71c4cb484e0c10333f25e0ca54d19513002b93803ae1677fb8ea05368253cd929853dfcda16207a53ed2f19f
+ sha512sums = ecf3a2d45a5393410ddc93444c01174745cddc9c07b52347c7e3635b4e1ce3d87cf6c332f8767034f1a219603f929ab2f821c7157f564b630de4d0eba11045f0
pkgname = looking-glass
pkgdesc = A client application for accessing the LookingGlass IVSHMEM device of a VM
diff --git a/PKGBUILD b/PKGBUILD
index e607a9ac20f6..ef52a64463ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,21 @@ pkgname=("${pkgbase}" "${pkgbase}-module-dkms" "${pkgbase}-host")
epoch=2
pkgver=B1
_pkgver=${pkgver//_/-}
-pkgrel=1
+pkgrel=2
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.hostfission.com"
arch=('x86_64')
license=('GPL2')
makedepends=('cmake' 'sdl2_ttf' 'glu' 'fontconfig' 'spice-protocol')
-source=("https://github.com/gnif/LookingGlass/archive/${_pkgver}.tar.gz")
-sha512sums=('add82702d7e7f601a07db5b9e0de7a7472d3051a71c4cb484e0c10333f25e0ca54d19513002b93803ae1677fb8ea05368253cd929853dfcda16207a53ed2f19f')
+source=("https://github.com/gnif/LookingGlass/archive/${_pkgver}.tar.gz"
+ "https://github.com/gnif/LookingGlass/pull/241.diff")
+sha512sums=('add82702d7e7f601a07db5b9e0de7a7472d3051a71c4cb484e0c10333f25e0ca54d19513002b93803ae1677fb8ea05368253cd929853dfcda16207a53ed2f19f'
+ 'ecf3a2d45a5393410ddc93444c01174745cddc9c07b52347c7e3635b4e1ce3d87cf6c332f8767034f1a219603f929ab2f821c7157f564b630de4d0eba11045f0')
+
+prepare() {
+ cd "${srcdir}/LookingGlass-${_pkgver}"
+ patch -i "${srcdir}/241.diff" -u common/src/crash.linux.c
+}
build() {
cd "${srcdir}/LookingGlass-${_pkgver}"