summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2018-12-21 13:26:51 +0100
committerOmar Pakker2018-12-21 13:26:51 +0100
commit87e4833cff9f74dc9860f525232e8a85791c86c5 (patch)
treec4e8b7ee377f8e065af2cdf8e8db3497067231b2
parenta69630764bbed0f1a5a3c11e7bc434b37e442e13 (diff)
downloadaur-87e4833cff9f74dc9860f525232e8a85791c86c5.tar.gz
Backport changes made in looking-glass-git now that a12 has been released.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf575e204070..fe1331718fee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = looking-glass
pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
- pkgver = a11
+ pkgver = a12
pkgrel = 1
url = https://looking-glass.hostfission.com
arch = x86_64
license = GPL2
+ makedepends = cmake
makedepends = sdl2_ttf
makedepends = glu
makedepends = fontconfig
makedepends = libconfig
makedepends = spice-protocol
- source = https://github.com/gnif/LookingGlass/archive/a11.tar.gz
+ source = https://github.com/gnif/LookingGlass/archive/a12.tar.gz
source = dkms.conf
- sha512sums = 1e44f91053c364ec074d370d93351d2c4e835f1e67ad62837620461032b83d79179319fb423a89af938edf0e4069ec32e023969badcf6f1effd955c69488d236
+ sha512sums = 72fa8bd1f8ced79bbd81784f9a8502cc39b9eea4d74caf7d27a98da29a2aa58abe71349661800f0b16cecd477ffb6b9a71e35abb68b942f3dad54fe339a70c47
sha512sums = e1f6cd6aabd336d2af97b44a2746e5a0b41d5d5942993379b1284d1cc8d4981fced0ae44d8105709f2bc45a939dfc7f229018c680b0742c3f0778fe28ba301f8
pkgname = looking-glass
diff --git a/PKGBUILD b/PKGBUILD
index 4dc11d977087..af6ec39c4976 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,21 @@
pkgbase=looking-glass
pkgname=("${pkgbase}" "${pkgbase}-module-dkms")
-pkgver=a11
+pkgver=a12
pkgrel=1
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.hostfission.com"
arch=('x86_64')
license=('GPL2')
-makedepends=('sdl2_ttf' 'glu' 'fontconfig' 'libconfig' 'spice-protocol')
+makedepends=('cmake' 'sdl2_ttf' 'glu' 'fontconfig' 'libconfig' 'spice-protocol')
source=("https://github.com/gnif/LookingGlass/archive/${pkgver}.tar.gz"
"dkms.conf")
-sha512sums=('1e44f91053c364ec074d370d93351d2c4e835f1e67ad62837620461032b83d79179319fb423a89af938edf0e4069ec32e023969badcf6f1effd955c69488d236'
+sha512sums=('72fa8bd1f8ced79bbd81784f9a8502cc39b9eea4d74caf7d27a98da29a2aa58abe71349661800f0b16cecd477ffb6b9a71e35abb68b942f3dad54fe339a70c47'
'e1f6cd6aabd336d2af97b44a2746e5a0b41d5d5942993379b1284d1cc8d4981fced0ae44d8105709f2bc45a939dfc7f229018c680b0742c3f0778fe28ba301f8')
build() {
cd "LookingGlass-${pkgver}/client"
+ cmake .
make
}
@@ -23,7 +24,7 @@ package_looking-glass() {
pkgdesc="A client application for accessing the LookingGlass IVSHMEM device of a VM"
depends=('sdl2_ttf' 'glu' 'nettle' 'fontconfig' 'libconfig')
- install -Dm755 "LookingGlass-${pkgver}/client/bin/looking-glass-client" "${pkgdir}/usr/bin/looking-glass-client"
+ install -Dm755 "LookingGlass-${pkgver}/client/looking-glass-client" "${pkgdir}/usr/bin/looking-glass-client"
}
package_looking-glass-module-dkms() {