summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2022-06-11 17:24:36 +0000
committerOmar Pakker2022-06-11 17:24:36 +0000
commita32b9daf07c51699eb512f7e23df5426e8685a9c (patch)
treeb3ef2c7dcbd3ada00850ddbc10c7aaf285307e83
parentb4e3e55481065f06b1abd3277b7d88c86aa12ed9 (diff)
downloadaur-a32b9daf07c51699eb512f7e23df5426e8685a9c.tar.gz
Quick fix for DKMS module on 5.18
In lieu of a new upstream release, ensure the package is still functioning. This makes the DKMS module work with the current Arch kernel (5.18).
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e2ee844a3cf..5ea52080713b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=("${pkgbase}"
"obs-plugin-${pkgbase}")
epoch=2
pkgver=B5.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.io/"
arch=('x86_64')
@@ -19,6 +19,10 @@ sha512sums=('bb3a2a6887f5d3f283b5bd4ebbead669331b9e87421ae2af00d730aba89bed8b04c
_lgdir="${pkgbase}-${pkgver}"
+prepare() {
+ sed -i '30a #include <linux/memremap.h>' "${srcdir}/${_lgdir}/module/kvmfr.c"
+}
+
build() {
cd "${srcdir}/${_lgdir}"
for b in {client,host,obs}/build; do