summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2018-06-02 16:50:55 +0200
committerOmar Pakker2018-06-02 16:50:55 +0200
commita69630764bbed0f1a5a3c11e7bc434b37e442e13 (patch)
tree89305bf6dd45e2493f976a57144b374195d6016e
parent8c8978b33b6cace4254a121271a5de13776dec4a (diff)
downloadaur-a69630764bbed0f1a5a3c11e7bc434b37e442e13.tar.gz
Update to version a11 and add the new kernel module.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
-rw-r--r--dkms.conf7
3 files changed, 49 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3b9fca4ee19..cf575e204070 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,29 @@
pkgbase = looking-glass
pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
- pkgver = a10
+ pkgver = a11
pkgrel = 1
url = https://looking-glass.hostfission.com
arch = x86_64
license = GPL2
makedepends = sdl2_ttf
+ makedepends = glu
+ makedepends = fontconfig
+ makedepends = libconfig
makedepends = spice-protocol
+ source = https://github.com/gnif/LookingGlass/archive/a11.tar.gz
+ source = dkms.conf
+ sha512sums = 1e44f91053c364ec074d370d93351d2c4e835f1e67ad62837620461032b83d79179319fb423a89af938edf0e4069ec32e023969badcf6f1effd955c69488d236
+ sha512sums = e1f6cd6aabd336d2af97b44a2746e5a0b41d5d5942993379b1284d1cc8d4981fced0ae44d8105709f2bc45a939dfc7f229018c680b0742c3f0778fe28ba301f8
+
+pkgname = looking-glass
+ pkgdesc = A client application for accessing the LookingGlass IVSHMEM device of a VM
depends = sdl2_ttf
depends = glu
- depends = openssl
+ depends = nettle
depends = fontconfig
- source = https://github.com/gnif/LookingGlass/archive/a10.tar.gz
- sha512sums = d58e12218064b41615a579ef0b4e728e6ebbe336ee4a1b6990f6a20c4a434bc4e7892f7ad8a8788c18d48b217b9d6291c5a7648d84be72cbcb909222e1a879ab
+ depends = libconfig
-pkgname = looking-glass
+pkgname = looking-glass-module-dkms
+ pkgdesc = A kernel module that implements a basic interface to the IVSHMEM device for when using LookingGlass in VM->VM mode
+ depends = dkms
diff --git a/PKGBUILD b/PKGBUILD
index 2220c879c0cf..4dc11d977087 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,41 @@
# Maintainer: Omar Pakker <archlinux@opakker.nl>
-pkgname=looking-glass
-pkgver=a10
+pkgbase=looking-glass
+pkgname=("${pkgbase}" "${pkgbase}-module-dkms")
+pkgver=a11
pkgrel=1
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.hostfission.com"
arch=('x86_64')
license=('GPL2')
-makedepends=('sdl2_ttf' 'spice-protocol')
-depends=('sdl2_ttf' 'glu' 'openssl' 'fontconfig')
-source=("https://github.com/gnif/LookingGlass/archive/${pkgver}.tar.gz")
-sha512sums=('d58e12218064b41615a579ef0b4e728e6ebbe336ee4a1b6990f6a20c4a434bc4e7892f7ad8a8788c18d48b217b9d6291c5a7648d84be72cbcb909222e1a879ab')
+makedepends=('sdl2_ttf' 'glu' 'fontconfig' 'libconfig' 'spice-protocol')
+source=("https://github.com/gnif/LookingGlass/archive/${pkgver}.tar.gz"
+ "dkms.conf")
+sha512sums=('1e44f91053c364ec074d370d93351d2c4e835f1e67ad62837620461032b83d79179319fb423a89af938edf0e4069ec32e023969badcf6f1effd955c69488d236'
+ 'e1f6cd6aabd336d2af97b44a2746e5a0b41d5d5942993379b1284d1cc8d4981fced0ae44d8105709f2bc45a939dfc7f229018c680b0742c3f0778fe28ba301f8')
build() {
cd "LookingGlass-${pkgver}/client"
make
}
-package() {
+package_looking-glass() {
+ pkgdesc="A client application for accessing the LookingGlass IVSHMEM device of a VM"
+ depends=('sdl2_ttf' 'glu' 'nettle' 'fontconfig' 'libconfig')
+
install -Dm755 "LookingGlass-${pkgver}/client/bin/looking-glass-client" "${pkgdir}/usr/bin/looking-glass-client"
}
+
+package_looking-glass-module-dkms() {
+ pkgdesc="A kernel module that implements a basic interface to the IVSHMEM device for when using LookingGlass in VM->VM mode"
+ depends=('dkms')
+
+ install -Dm644 "${srcdir}/dkms.conf" "${pkgdir}/usr/src/${pkgbase}-${pkgver}/dkms.conf"
+
+ # Set module name and version
+ sed -e "s/@PKGNAME@/${pkgbase}/" \
+ -e "s/@PKGVER@/${pkgver}/" \
+ -i "${pkgdir}/usr/src/${pkgbase}-${pkgver}/dkms.conf"
+
+ cp -r "${srcdir}/LookingGlass-${pkgver}/module/"* "${pkgdir}/usr/src/${pkgbase}-${pkgver}/"
+}
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..a989e6aedc11
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,7 @@
+PACKAGE_NAME="@PKGNAME@"
+PACKAGE_VERSION="@PKGVER@"
+MAKE[0]="make"
+CLEAN="make clean"
+BUILT_MODULE_NAME[0]="kvmfr"
+DEST_MODULE_LOCATION[0]="/kernel/drivers/misc"
+AUTOINSTALL="yes"