summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2022-12-24 14:35:51 +0000
committerOmar Pakker2022-12-24 14:35:51 +0000
commitaaeea450df7d070d5042f48c7cc325e9101abd88 (patch)
tree30fdf34dbbea486e405d8c5f64262fcb5f1ffdf4
parenta01d19eea63c4884338061bd778b2c6b37c7d6aa (diff)
downloadaur-aaeea450df7d070d5042f48c7cc325e9101abd88.tar.gz
Update to B6 release.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 353a8e5dc10c..216b3251f595 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = looking-glass
pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
- pkgver = B5.0.1
- pkgrel = 3
+ pkgver = B6
+ pkgrel = 1
epoch = 2
url = https://looking-glass.io/
arch = x86_64
@@ -14,8 +14,11 @@ pkgbase = looking-glass
makedepends = libxi
makedepends = libxpresent
makedepends = obs-studio
- source = looking-glass-B5.0.1.tar.gz::https://looking-glass.io/artifact/B5.0.1/source
- sha512sums = 2600722fba5a9b794556391a636df09d284dc5460c5e9b4718bc2c044e6ece68890893c18c30780245207c0e92194f9691269bdcd590f118a616417d1e74bbd6
+ makedepends = pipewire
+ makedepends = libpulse
+ makedepends = libsamplerate
+ source = looking-glass-B6.tar.gz::https://looking-glass.io/artifact/B6/source
+ sha512sums = 402729dc51a6e8995a64384de6e9549861a0db6a87c9627e5832ea548b4ab6b49f538cf12ae510caa360c39806671785ce7560aaf07e7c46532fe0271884f2cb
pkgname = looking-glass
pkgdesc = A client application for accessing the LookingGlass IVSHMEM device of a VM
@@ -29,6 +32,9 @@ pkgname = looking-glass
depends = libxcursor
depends = libxpresent
depends = libxkbcommon
+ depends = pipewire
+ depends = libpulse
+ depends = libsamplerate
pkgname = looking-glass-module-dkms
pkgdesc = A kernel module that implements a basic interface to the IVSHMEM device for when using LookingGlass in VM->VM mode
@@ -38,6 +44,7 @@ pkgname = looking-glass-host
pkgdesc = Linux host application for pushing frame data to the LookingGlass IVSHMEM device
depends = libxcb
depends = zlib
+ depends = pipewire
pkgname = obs-plugin-looking-glass
pkgdesc = Plugin for OBS Studio to stream directly from Looking Glass without having to record the Looking Glass client
diff --git a/PKGBUILD b/PKGBUILD
index 299d69693365..2c5d645aa904 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,23 +6,20 @@ pkgname=("${pkgbase}"
"${pkgbase}-host"
"obs-plugin-${pkgbase}")
epoch=2
-pkgver=B5.0.1
-pkgrel=3
+pkgver=B6
+pkgrel=1
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.io/"
arch=('x86_64')
license=('GPL2')
makedepends=('cmake' 'fontconfig' 'spice-protocol' 'wayland-protocols'
- 'libxss' 'libxi' 'libxpresent' 'obs-studio')
+ 'libxss' 'libxi' 'libxpresent' 'obs-studio' 'pipewire' 'libpulse'
+ 'libsamplerate')
source=("looking-glass-${pkgver}.tar.gz::https://looking-glass.io/artifact/${pkgver}/source")
-sha512sums=('2600722fba5a9b794556391a636df09d284dc5460c5e9b4718bc2c044e6ece68890893c18c30780245207c0e92194f9691269bdcd590f118a616417d1e74bbd6')
+sha512sums=('402729dc51a6e8995a64384de6e9549861a0db6a87c9627e5832ea548b4ab6b49f538cf12ae510caa360c39806671785ce7560aaf07e7c46532fe0271884f2cb')
_lgdir="${pkgbase}-${pkgver}"
-prepare() {
- sed -i '30a #include <linux/memremap.h>' "${srcdir}/${_lgdir}/module/kvmfr.c"
-}
-
build() {
cd "${srcdir}/${_lgdir}"
for b in {client,host,obs}/build; do
@@ -37,7 +34,8 @@ build() {
package_looking-glass() {
pkgdesc="A client application for accessing the LookingGlass IVSHMEM device of a VM"
depends=('libgl' 'libegl' 'nettle' 'fontconfig' 'libxss' 'libxi'
- 'libxinerama' 'libxcursor' 'libxpresent' 'libxkbcommon')
+ 'libxinerama' 'libxcursor' 'libxpresent' 'libxkbcommon'
+ 'pipewire' 'libpulse' 'libsamplerate')
cd "${srcdir}/${_lgdir}/client/build"
make DESTDIR="${pkgdir}" install
@@ -56,7 +54,7 @@ package_looking-glass-module-dkms() {
package_looking-glass-host() {
pkgdesc="Linux host application for pushing frame data to the LookingGlass IVSHMEM device"
- depends=('libxcb' 'zlib')
+ depends=('libxcb' 'zlib' 'pipewire')
cd "${srcdir}/${_lgdir}/host/build"
make DESTDIR="${pkgdir}" install