summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2017-12-22 17:49:45 +0100
committerOmar Pakker2017-12-22 17:49:45 +0100
commite4a63f784e6fc9106f7df4be9f05cb05ff8fa97f (patch)
treed8d8c3665d3b11a16ccd9019515b7c7965a46c1b
downloadaur-e4a63f784e6fc9106f7df4be9f05cb05ff8fa97f.tar.gz
Initial commit for tagged releases package of Looking Glass.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc9f1f2e829a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = looking-glass
+ pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
+ pkgver = a9
+ pkgrel = 1
+ url = https://looking-glass.hostfission.com
+ arch = x86_64
+ license = GPL2
+ makedepends = sdl2_ttf
+ makedepends = spice-protocol
+ depends = sdl2_ttf
+ depends = glu
+ depends = openssl
+ depends = fontconfig
+ source = https://github.com/gnif/LookingGlass/archive/a9.tar.gz
+ sha512sums = e1921dd3f5d209ba584270dc78629303840c6c586eaced2813654944264309645d964185bae1f8f76f4da721a0d5dfec41c277f02776dc0f567c88c6e845401b
+
+pkgname = looking-glass
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59229e81641b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Omar Pakker <archlinux@opakker.nl>
+
+pkgname=looking-glass
+pkgver=a9
+pkgrel=1
+pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
+url="https://looking-glass.hostfission.com"
+arch=('x86_64')
+license=('GPL2')
+makedepends=('sdl2_ttf' 'spice-protocol')
+depends=('sdl2_ttf' 'glu' 'openssl' 'fontconfig')
+source=("https://github.com/gnif/LookingGlass/archive/${pkgver}.tar.gz")
+sha512sums=('e1921dd3f5d209ba584270dc78629303840c6c586eaced2813654944264309645d964185bae1f8f76f4da721a0d5dfec41c277f02776dc0f567c88c6e845401b')
+
+build() {
+ cd "LookingGlass-${pkgver}/client"
+ make
+}
+
+package() {
+ install -Dm755 "LookingGlass-${pkgver}/client/bin/looking-glass-client" "${pkgdir}/usr/bin/looking-glass-client"
+}