summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2019-06-02 18:40:54 +0000
committerOmar Pakker2019-06-02 18:40:54 +0000
commit31a8e766709f789d6dbed4d4f6ea0ddc3b7a7433 (patch)
tree83e2a3085154881a0c81dc3b130a4ce76d729cbe
parent2996bcb90e48d7226114eaa167ca96f85c68579f (diff)
downloadaur-31a8e766709f789d6dbed4d4f6ea0ddc3b7a7433.tar.gz
Updated for B1-rc* releases; use provided dkms.conf, add linux c-host. Epoch bumped due to the inconsistent/alphanumeric versioning which causes the latest version to be seen as older
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD48
2 files changed, 39 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb6f5a5b6a70..a1c4752c4435 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = looking-glass-git
pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
- pkgver = a11.r41.g697dbc7
+ pkgver = B1_rc5.r6.g2b4f809
pkgrel = 1
+ epoch = 1
url = https://looking-glass.hostfission.com
install = looking-glass-git.install
arch = x86_64
@@ -14,9 +15,7 @@ pkgbase = looking-glass-git
makedepends = libconfig
makedepends = spice-protocol
source = looking-glass::git+https://github.com/gnif/LookingGlass.git
- source = dkms.conf
sha512sums = SKIP
- sha512sums = e1f6cd6aabd336d2af97b44a2746e5a0b41d5d5942993379b1284d1cc8d4981fced0ae44d8105709f2bc45a939dfc7f229018c680b0742c3f0778fe28ba301f8
pkgname = looking-glass-git
pkgdesc = A client application for accessing the LookingGlass IVSHMEM device of a VM
@@ -24,7 +23,6 @@ pkgname = looking-glass-git
depends = glu
depends = nettle
depends = fontconfig
- depends = libconfig
provides = looking-glass
conflicts = looking-glass
@@ -34,3 +32,10 @@ pkgname = looking-glass-module-dkms-git
provides = looking-glass-module-dkms
conflicts = looking-glass-module-dkms
+pkgname = looking-glass-host-git
+ pkgdesc = Linux host application for pushing frame data to the LookingGlass IVSHMEM device
+ depends = libxcb
+ depends = zlib
+ provides = looking-glass-host
+ conflicts = looking-glass-host
+
diff --git a/PKGBUILD b/PKGBUILD
index d893f43b635d..921dcd28ffdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,38 +2,44 @@
_pkgname=looking-glass
pkgbase="${_pkgname}-git"
-pkgname=("${_pkgname}-git" "${_pkgname}-module-dkms-git")
-pkgver=a11.r41.g697dbc7
+pkgname=("${_pkgname}-git" "${_pkgname}-module-dkms-git" "${_pkgname}-host-git")
+epoch=1
+pkgver=B1_rc5.r6.g2b4f809
pkgrel=1
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.hostfission.com"
arch=('x86_64')
license=('GPL2')
makedepends=('cmake' 'git' 'sdl2_ttf' 'glu' 'fontconfig' 'libconfig' 'spice-protocol')
-source=("${_pkgname}::git+https://github.com/gnif/LookingGlass.git"
- "dkms.conf")
-sha512sums=('SKIP'
- 'e1f6cd6aabd336d2af97b44a2746e5a0b41d5d5942993379b1284d1cc8d4981fced0ae44d8105709f2bc45a939dfc7f229018c680b0742c3f0778fe28ba301f8')
+source=("${_pkgname}::git+https://github.com/gnif/LookingGlass.git")
+sha512sums=('SKIP')
install="${pkgbase}.install"
pkgver() {
cd "${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ local TAG=$(git describe --abbrev=0 --tags)
+ local SUFFIX=$(git describe --long --tags | sed 's/^'"${TAG}"'-\([^-]*-g\)/r\1/;s/-/./g')
+ printf "%s.%s" "${TAG//-/_}" "${SUFFIX}"
}
build() {
- cd "${_pkgname}/client"
- cmake .
- make
+ cd "${srcdir}/${_pkgname}"
+ for b in {client,c-host}; do
+ pushd "${b}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+ popd
+ done
}
package_looking-glass-git() {
pkgdesc="A client application for accessing the LookingGlass IVSHMEM device of a VM"
- depends=('sdl2_ttf' 'glu' 'nettle' 'fontconfig' 'libconfig')
+ depends=('sdl2_ttf' 'glu' 'nettle' 'fontconfig')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
- install -Dm755 "${srcdir}/${_pkgname}/client/looking-glass-client" "${pkgdir}/usr/bin/looking-glass-client"
+ cd "${srcdir}/${_pkgname}/client"
+ make DESTDIR="${pkgdir}" install
}
package_looking-glass-module-dkms-git() {
@@ -42,12 +48,18 @@ package_looking-glass-module-dkms-git() {
provides=("${_pkgname}-module-dkms")
conflicts=("${_pkgname}-module-dkms")
- install -Dm644 "${srcdir}/dkms.conf" "${pkgdir}/usr/src/${_pkgname}-${pkgver}/dkms.conf"
+ cd "${srcdir}/${_pkgname}/module"
+ for f in {Makefile,dkms.conf,kvmfr.c}; do
+ install -Dm644 "${f}" "${pkgdir}/usr/src/${pkgbase}-${pkgver}/${f}"
+ done
+}
- # Set module name and version
- sed -e "s/@PKGNAME@/${_pkgname}/" \
- -e "s/@PKGVER@/${pkgver}/" \
- -i "${pkgdir}/usr/src/${_pkgname}-${pkgver}/dkms.conf"
+package_looking-glass-host-git() {
+ pkgdesc="Linux host application for pushing frame data to the LookingGlass IVSHMEM device"
+ depends=('libxcb' 'zlib')
+ provides=("${_pkgname}-host")
+ conflicts=("${_pkgname}-host")
- cp -r "${srcdir}/${_pkgname}/module/"* "${pkgdir}/usr/src/${_pkgname}-${pkgver}/"
+ cd "${srcdir}/${_pkgname}/c-host"
+ make DESTDIR="${pkgdir}" install
}