summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2021-08-19 15:08:54 +0000
committerOmar Pakker2021-08-19 15:08:54 +0000
commit6674f4fcec5e6b35362ebfb92c1f42e3e9c0da2b (patch)
treee1027f036931b8a5ff39aff570f51611e53b1571
parent2d9b963a9fc2db571c4c67f8bca27818dff1b5aa (diff)
downloadaur-6674f4fcec5e6b35362ebfb92c1f42e3e9c0da2b.tar.gz
Add libxkbcommon dependency. Introduced by upstream commit 70457604900eec31cf988b716f7b4518ab7d6927
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf7f7497c61b..22ff68038a24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = looking-glass-git
pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
- pkgver = B4.r249.gbae19cb1
+ pkgver = B4.r479.gc246b4a7
pkgrel = 1
epoch = 2
url = https://looking-glass.io/
@@ -38,6 +38,7 @@ pkgname = looking-glass-git
depends = libxinerama
depends = libxcursor
depends = libxpresent
+ depends = libxkbcommon
provides = looking-glass
conflicts = looking-glass
diff --git a/PKGBUILD b/PKGBUILD
index 1076a5451a86..dee6b7f404dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=("${_pkgname}-git"
"${_pkgname}-host-git"
"obs-plugin-${_pkgname}-git")
epoch=2
-pkgver=B4.r249.gbae19cb1
+pkgver=B4.r479.gc246b4a7
pkgrel=1
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.io/"
@@ -50,9 +50,10 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
- for b in {client,host,obs}; do
+ for b in {client,host,obs}/build; do
+ mkdir "${b}"
pushd "${b}"
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
popd
done
@@ -61,16 +62,12 @@ build() {
package_looking-glass-git() {
pkgdesc="A client application for accessing the LookingGlass IVSHMEM device of a VM"
depends=('libgl' 'libegl' 'nettle' 'fontconfig' 'libxss' 'libxi'
- 'libxinerama' 'libxcursor' 'libxpresent')
+ 'libxinerama' 'libxcursor' 'libxpresent' 'libxkbcommon')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
- cd "${srcdir}/${_pkgname}/client"
+ cd "${srcdir}/${_pkgname}/client/build"
make DESTDIR="${pkgdir}" install
-
- # cimgui is build and linked as a static library.
- # As such, it had no business getting installed. Delete it.
- rm "${pkgdir}/usr/cimgui.a"
}
package_looking-glass-module-dkms-git() {
@@ -92,7 +89,7 @@ package_looking-glass-host-git() {
provides=("${_pkgname}-host")
conflicts=("${_pkgname}-host")
- cd "${srcdir}/${_pkgname}/host"
+ cd "${srcdir}/${_pkgname}/host/build"
make DESTDIR="${pkgdir}" install
}
@@ -103,5 +100,5 @@ package_obs-plugin-looking-glass-git() {
conflicts=("obs-plugin-${_pkgname}")
install -Dm644 -t "${pkgdir}/usr/lib/obs-plugins" \
- "${srcdir}/${_pkgname}/obs/liblooking-glass-obs.so"
+ "${srcdir}/${_pkgname}/obs/build/liblooking-glass-obs.so"
}