summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2021-05-30 01:02:13 +0000
committerOmar Pakker2021-05-30 01:02:13 +0000
commitb63c9638ac4a6bb4d96489f4bfcc3bcb46bba3c5 (patch)
treee9b638e62e39057d4f89cebb426c460b804cfa80
parentf85620995f052bc520e802ea3ee955980922f796 (diff)
downloadaur-b63c9638ac4a6bb4d96489f4bfcc3bcb46bba3c5.tar.gz
Update dependencies; drop SDL2, add dependencies on GL and EGL.
The SDL2 displayserver component is now an optional/legacy and default disabled upstream. Provides 2 renderers; GL and EGL. SDL2 previously pulled these in transitively, now explicit.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 172ecb31b72a..0d1b8993082d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = looking-glass-git
pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
- pkgver = B3.r97.g30b5287
- pkgrel = 2
+ pkgver = B3.r236.g118d9a0
+ pkgrel = 1
epoch = 2
url = https://looking-glass.io/
install = looking-glass-git.install
@@ -9,10 +9,11 @@ pkgbase = looking-glass-git
license = GPL2
makedepends = cmake
makedepends = git
- makedepends = sdl2_ttf
makedepends = fontconfig
makedepends = spice-protocol
makedepends = wayland-protocols
+ makedepends = libgl
+ makedepends = libegl
makedepends = libxss
makedepends = libxi
makedepends = libxinerama
@@ -26,7 +27,8 @@ pkgbase = looking-glass-git
pkgname = looking-glass-git
pkgdesc = A client application for accessing the LookingGlass IVSHMEM device of a VM
- depends = sdl2_ttf
+ depends = libgl
+ depends = libegl
depends = nettle
depends = fontconfig
depends = libxss
diff --git a/PKGBUILD b/PKGBUILD
index e2ff932bf41c..8cf76621c76a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,14 @@ pkgname=("${_pkgname}-git"
"${_pkgname}-host-git"
"obs-plugin-${_pkgname}-git")
epoch=2
-pkgver=B3.r97.g30b5287
-pkgrel=2
+pkgver=B3.r236.g118d9a0
+pkgrel=1
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.io/"
arch=('x86_64')
license=('GPL2')
-makedepends=('cmake' 'git' 'sdl2_ttf' 'fontconfig' 'spice-protocol' 'wayland-protocols'
- 'libxss' 'libxi' 'libxinerama' 'obs-studio')
+makedepends=('cmake' 'git' 'fontconfig' 'spice-protocol' 'wayland-protocols'
+ 'libgl' 'libegl' 'libxss' 'libxi' 'libxinerama' 'obs-studio')
source=("${_pkgname}::git+https://github.com/gnif/LookingGlass.git"
"LGMP::git+https://github.com/gnif/LGMP.git"
"PureSpice::git+https://github.com/gnif/PureSpice.git")
@@ -51,7 +51,7 @@ build() {
package_looking-glass-git() {
pkgdesc="A client application for accessing the LookingGlass IVSHMEM device of a VM"
- depends=('sdl2_ttf' 'nettle' 'fontconfig' 'libxss' 'libxi' 'libxinerama')
+ depends=('libgl' 'libegl' 'nettle' 'fontconfig' 'libxss' 'libxi' 'libxinerama')
provides=("${_pkgname}")
conflicts=("${_pkgname}")