summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2018-06-02 17:07:00 +0200
committerOmar Pakker2018-06-02 17:07:00 +0200
commitc13c9c0214b3d26d2d9c2779c8f5c8b2dc78cd41 (patch)
tree26deaca1e1f34d685a57241e1e597944bac0fc5c
parent547439c1ecb8bd7803b189e4faafa19cb90286b2 (diff)
downloadaur-c13c9c0214b3d26d2d9c2779c8f5c8b2dc78cd41.tar.gz
Nettle has replaced openssl and the project has been changed to use cmake.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f24ecc4f1a5..c57224508674 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = looking-glass-git
pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
- pkgver = a10.r67.gf63c804
- pkgrel = 2
+ pkgver = a11.r29.g8a9d0b0
+ pkgrel = 1
url = https://looking-glass.hostfission.com
arch = x86_64
license = GPL2
+ makedepends = cmake
makedepends = git
makedepends = sdl2_ttf
makedepends = glu
@@ -20,7 +21,7 @@ pkgname = looking-glass-git
pkgdesc = A client application for accessing the LookingGlass IVSHMEM device of a VM
depends = sdl2_ttf
depends = glu
- depends = openssl
+ depends = nettle
depends = fontconfig
depends = libconfig
provides = looking-glass
diff --git a/PKGBUILD b/PKGBUILD
index 0eff39dd6e27..96096dc190d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
_pkgname=looking-glass
pkgbase="${_pkgname}-git"
pkgname=("${_pkgname}-git" "${_pkgname}-module-dkms-git")
-pkgver=a10.r67.gf63c804
-pkgrel=2
+pkgver=a11.r29.g8a9d0b0
+pkgrel=1
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.hostfission.com"
arch=('x86_64')
license=('GPL2')
-makedepends=('git' 'sdl2_ttf' 'glu' 'fontconfig' 'libconfig' 'spice-protocol')
+makedepends=('cmake' 'git' 'sdl2_ttf' 'glu' 'fontconfig' 'libconfig' 'spice-protocol')
source=("${_pkgname}::git+https://github.com/gnif/LookingGlass.git"
"dkms.conf")
sha512sums=('SKIP'
@@ -22,16 +22,17 @@ pkgver() {
build() {
cd "${_pkgname}/client"
+ cmake .
make
}
package_looking-glass-git() {
pkgdesc="A client application for accessing the LookingGlass IVSHMEM device of a VM"
- depends=('sdl2_ttf' 'glu' 'openssl' 'fontconfig' 'libconfig')
+ depends=('sdl2_ttf' 'glu' 'nettle' 'fontconfig' 'libconfig')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
- install -Dm755 "${srcdir}/${_pkgname}/client/bin/looking-glass-client" "${pkgdir}/usr/bin/looking-glass-client"
+ install -Dm755 "${srcdir}/${_pkgname}/client/looking-glass-client" "${pkgdir}/usr/bin/looking-glass-client"
}
package_looking-glass-module-dkms-git() {