summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2021-02-22 13:03:54 +0000
committerOmar Pakker2021-02-22 13:03:54 +0000
commitf85620995f052bc520e802ea3ee955980922f796 (patch)
tree8d59ba43dbf8c64d6b27e05768aa110158e2ee76
parentfadb45ef6e21cba915d52fba29f3532f950f23d1 (diff)
downloadaur-f85620995f052bc520e802ea3ee955980922f796.tar.gz
Re-add Linux host application as it builds again.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 29 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c1a43854fda..172ecb31b72a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = looking-glass-git
pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
- pkgver = B2.r345.g428b498
- pkgrel = 1
+ pkgver = B3.r97.g30b5287
+ pkgrel = 2
epoch = 2
url = https://looking-glass.io/
install = looking-glass-git.install
@@ -10,13 +10,13 @@ pkgbase = looking-glass-git
makedepends = cmake
makedepends = git
makedepends = sdl2_ttf
- makedepends = glu
makedepends = fontconfig
makedepends = spice-protocol
+ makedepends = wayland-protocols
makedepends = libxss
makedepends = libxi
+ makedepends = libxinerama
makedepends = obs-studio
- makedepends = wayland-protocols
source = looking-glass::git+https://github.com/gnif/LookingGlass.git
source = LGMP::git+https://github.com/gnif/LGMP.git
source = PureSpice::git+https://github.com/gnif/PureSpice.git
@@ -27,11 +27,11 @@ pkgbase = looking-glass-git
pkgname = looking-glass-git
pkgdesc = A client application for accessing the LookingGlass IVSHMEM device of a VM
depends = sdl2_ttf
- depends = glu
depends = nettle
depends = fontconfig
depends = libxss
depends = libxi
+ depends = libxinerama
provides = looking-glass
conflicts = looking-glass
@@ -41,6 +41,13 @@ pkgname = looking-glass-module-dkms-git
provides = looking-glass-module-dkms
conflicts = looking-glass-module-dkms
+pkgname = looking-glass-host-git
+ pkgdesc = Linux host application for pushing frame data to the LookingGlass IVSHMEM device
+ depends = libxcb
+ depends = zlib
+ provides = looking-glass-host
+ conflicts = looking-glass-host
+
pkgname = obs-plugin-looking-glass-git
pkgdesc = Plugin for OBS Studio to stream directly from Looking Glass without having to record the Looking Glass client
depends = obs-studio
diff --git a/PKGBUILD b/PKGBUILD
index 9664642ade77..e2ff932bf41c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,17 @@ _pkgname=looking-glass
pkgbase="${_pkgname}-git"
pkgname=("${_pkgname}-git"
"${_pkgname}-module-dkms-git"
+ "${_pkgname}-host-git"
"obs-plugin-${_pkgname}-git")
epoch=2
-pkgver=B2.r345.g428b498
-pkgrel=1
+pkgver=B3.r97.g30b5287
+pkgrel=2
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.io/"
arch=('x86_64')
license=('GPL2')
-makedepends=('cmake' 'git' 'sdl2_ttf' 'glu' 'fontconfig' 'spice-protocol'
- 'libxss' 'libxi' 'obs-studio' 'wayland-protocols')
+makedepends=('cmake' 'git' 'sdl2_ttf' 'fontconfig' 'spice-protocol' 'wayland-protocols'
+ 'libxss' 'libxi' 'libxinerama' 'obs-studio')
source=("${_pkgname}::git+https://github.com/gnif/LookingGlass.git"
"LGMP::git+https://github.com/gnif/LGMP.git"
"PureSpice::git+https://github.com/gnif/PureSpice.git")
@@ -40,7 +41,7 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
- for b in {client,obs}; do
+ for b in {client,host,obs}; do
pushd "${b}"
cmake -DCMAKE_INSTALL_PREFIX=/usr .
make
@@ -50,7 +51,7 @@ build() {
package_looking-glass-git() {
pkgdesc="A client application for accessing the LookingGlass IVSHMEM device of a VM"
- depends=('sdl2_ttf' 'glu' 'nettle' 'fontconfig' 'libxss' 'libxi')
+ depends=('sdl2_ttf' 'nettle' 'fontconfig' 'libxss' 'libxi' 'libxinerama')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
@@ -71,6 +72,16 @@ package_looking-glass-module-dkms-git() {
kvmfr.{h,c}
}
+package_looking-glass-host-git() {
+ pkgdesc="Linux host application for pushing frame data to the LookingGlass IVSHMEM device"
+ depends=('libxcb' 'zlib')
+ provides=("${_pkgname}-host")
+ conflicts=("${_pkgname}-host")
+
+ cd "${srcdir}/${_pkgname}/host"
+ make DESTDIR="${pkgdir}" install
+}
+
package_obs-plugin-looking-glass-git() {
pkgdesc="Plugin for OBS Studio to stream directly from Looking Glass without having to record the Looking Glass client"
depends=('obs-studio')