summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredtide2021-10-14 00:08:06 +0200
committerredtide2021-10-14 00:08:06 +0200
commit84b3e71cf486d0df45039f05e49a3417587f5071 (patch)
tree3163a95d4cf00be86f40ee67d884334b9dec3433
parent2ee00b2e985532ade9e74590081b52b6abd1d7b8 (diff)
downloadaur-84b3e71cf486d0df45039f05e49a3417587f5071.tar.gz
Sources update
-rw-r--r--PKGBUILD12
-rw-r--r--loopauditioneer-datadir.diff13
2 files changed, 14 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c08dd4b55bba..d475cbedb32a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Contributor: Joermungand <joermungand at gmail dot com>
pkgname=loopauditioneer-svn
-pkgver=r54
-pkgrel=2
+pkgver=r62
+pkgrel=1
pkgdesc="Software for loop and cue handling in .wav files"
arch=('i686' 'x86_64')
url="http://loopauditioneer.sourceforge.net/"
license=('GPL3')
-depends=('wxgtk3' 'webkit2gtk' 'rtaudio')
+depends=('wxgtk3' 'webkit2gtk' 'rtaudio' 'libsamplerate')
makedepends=('svn')
provides=('loopauditioneer')
conflicts=('loopauditioneer')
@@ -17,10 +17,11 @@ source=("${pkgname%-*}"::'svn://svn.code.sf.net/p/loopauditioneer/code/trunk'
'loopauditioneer-datadir.diff'
"${pkgname%-*}.desktop")
md5sums=('SKIP'
- '2aaf74119fab99191937d0f38f47b02e'
+ '2a48bc667b0f4b01aeb7d9c3c9a7319a'
'0e2286c155701065663461be6c1056ba')
_cpp_sources=(
+ AudioSettingsDialog.cpp
AutoLoopDialog.cpp
AutoLooping.cpp
BatchProcessDialog.cpp
@@ -37,6 +38,7 @@ _cpp_sources=(
MyFrame.cpp
MyListCtrl.cpp
MyPanel.cpp
+ MyResampler.cpp
MySound.cpp
PitchDialog.cpp
StopHarmonicDialog.cpp
@@ -51,7 +53,6 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-*}"
-
patch -p1 -N -r - -i "$srcdir"/loopauditioneer-datadir.diff || true
}
@@ -83,6 +84,7 @@ build() {
`pkg-config --cflags --libs rtaudio` \
-lm \
-lpthread \
+ -lsamplerate \
`wx-config-gtk3 --cxxflags --unicode=yes --libs` \
)
}
diff --git a/loopauditioneer-datadir.diff b/loopauditioneer-datadir.diff
index a98582ce7fb3..71054b4b82a2 100644
--- a/loopauditioneer-datadir.diff
+++ b/loopauditioneer-datadir.diff
@@ -1,13 +1,14 @@
diff --git a/src/LoopAuditioneer.cpp b/src/LoopAuditioneer.cpp
-index ed2832a..ea1a855 100644
+index 7f5b567..4f8b715 100644
--- a/src/LoopAuditioneer.cpp
+++ b/src/LoopAuditioneer.cpp
-@@ -41,13 +41,13 @@ bool LoopAuditioneerApp::OnInit() {
+@@ -41,14 +41,14 @@ bool LoopAuditioneerApp::OnInit() {
wxImage::AddHandler(new wxJPEGHandler);
wxFileSystem::AddHandler(new wxZipFSHandler);
m_helpController = new wxHtmlHelpController();
-- m_helpController->Initialize(wxT("help/help.zip"));
-+ m_helpController->Initialize(wxT(DATADIR "/help/help.zip"));
+- m_helpController->AddBook(wxFileName("help/help.zip"));
++ m_helpController->AddBook(wxFileName(DATADIR "/help/help.zip"));
+ m_helpController->SetFrameParameters(wxT("%s"), wxDefaultSize, wxDefaultPosition);
// load icons
- m_icons = wxIconBundle(wxIcon(wxT("icons/LoopyIcon-16.png"), wxBITMAP_TYPE_PNG));
@@ -22,10 +23,10 @@ index ed2832a..ea1a855 100644
frame->SetIcons(m_icons);
diff --git a/src/MyFrame.cpp b/src/MyFrame.cpp
-index 5e2f8c0..902d308 100644
+index ba1dfeb..73dc58d 100644
--- a/src/MyFrame.cpp
+++ b/src/MyFrame.cpp
-@@ -680,23 +680,23 @@ MyFrame::MyFrame(const wxString& title) : wxFrame(NULL, wxID_ANY, title), m_time
+@@ -766,23 +766,23 @@ MyFrame::MyFrame(const wxString& title) : wxFrame(NULL, wxID_ANY, title), m_time
toolBar = CreateToolBar(wxNO_BORDER | wxTB_HORIZONTAL | wxTB_FLAT);
toolBar->SetToolBitmapSize(wxSize(24, 24));
wxImage::AddHandler(new wxPNGHandler);