summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredtide2021-04-13 00:54:37 +0200
committerredtide2021-04-13 00:54:37 +0200
commita345be2fdcf7d1d189e22a81b18295e56ccc5e75 (patch)
tree093617f3f68ebcbab04a087ca06caa98e8f362cc
parent010127c3d3e6b2b9dc5e83d22b621121cc566d8f (diff)
downloadaur-a345be2fdcf7d1d189e22a81b18295e56ccc5e75.tar.gz
Update from SpotlightKid, see CHANGELOG.md
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--CHANGELOG.md11
-rw-r--r--PKGBUILD144
-rw-r--r--loopauditioneer-datadir.diff68
-rwxr-xr-xloopauditioneer.sh5
6 files changed, 177 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 602f76f73e48..6f074adb2025 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = loopauditioneer-svn
pkgdesc = Software for loop and cue handling in .wav files
pkgver = r54
- pkgrel = 1
+ pkgrel = 2
url = http://loopauditioneer.sourceforge.net/
arch = i686
arch = x86_64
license = GPL3
makedepends = svn
- depends = wxgtk2
- depends = alsa-lib
- depends = gcc-libs-multilib
+ depends = wxgtk3
+ depends = webkit2gtk
+ depends = rtaudio
provides = loopauditioneer
conflicts = loopauditioneer
source = loopauditioneer::svn://svn.code.sf.net/p/loopauditioneer/code/trunk
- source = loopauditioneer.sh
+ source = loopauditioneer-datadir.diff
source = loopauditioneer.desktop
md5sums = SKIP
- md5sums = 1ea7cc51c813bfe8e37a7ebb15184948
+ md5sums = 2aaf74119fab99191937d0f38f47b02e
md5sums = 0e2286c155701065663461be6c1056ba
pkgname = loopauditioneer-svn
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2c8f05efc523
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+loopauditioneer/
+loopauditioneer-svn-*.pkg.tar.xz
+loopauditioneer-svn-*.pkg.tar.zst
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..32eecb146558
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,11 @@
+Various PKGBUILD improvements
+
+* Compiled with wxgtk3 instead of wxgtk2
+* Used system rtaudio library.
+* Updated 'depends'.
+* Moved files under /usr (using patch to fix icon/help file paths).
+* Removed installation of unneeded / duplicated icon/help files.
+* Removed now unneeded starter shell script.
+* Installed icons license.
+* Cleaned up and re-structured build and install commands.
+* Added .gitignore.
diff --git a/PKGBUILD b/PKGBUILD
index 431cc6ff420d..f7cd43d42ac9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,79 +1,109 @@
-# Maintainer: Joermungand <joermungand at gmail dot com>
+# Maintainer: redtide <redtid3 at gmail dot com>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Contributor: Joermungand <joermungand at gmail dot com>
pkgname=loopauditioneer-svn
pkgver=r54
-pkgrel=1
+pkgrel=2
pkgdesc="Software for loop and cue handling in .wav files"
arch=('i686' 'x86_64')
url="http://loopauditioneer.sourceforge.net/"
license=('GPL3')
-depends=('wxgtk2' 'alsa-lib' 'gcc-libs-multilib')
+depends=('wxgtk3' 'webkit2gtk' 'rtaudio')
makedepends=('svn')
provides=('loopauditioneer')
conflicts=('loopauditioneer')
source=("${pkgname%-*}"::'svn://svn.code.sf.net/p/loopauditioneer/code/trunk'
- "${pkgname%-*}.sh"
+ 'loopauditioneer-datadir.diff'
"${pkgname%-*}.desktop")
-md5sums=(SKIP
- '1ea7cc51c813bfe8e37a7ebb15184948'
+md5sums=('SKIP'
+ '2aaf74119fab99191937d0f38f47b02e'
'0e2286c155701065663461be6c1056ba')
-pkgver(){
- cd "$srcdir/${pkgname%-*}"
- local ver="$(svnversion)"
- printf "r%s" "${ver//[[:alpha:]]}"
+_cpp_sources=(
+ AutoLoopDialog.cpp
+ AutoLooping.cpp
+ BatchProcessDialog.cpp
+ CrossfadeDialog.cpp
+ CueMarkers.cpp
+ CutNFadeDialog.cpp
+ FFT.cpp
+ FileHandling.cpp
+ ListInfoDialog.cpp
+ LoopAuditioneer.cpp
+ LoopMarkers.cpp
+ LoopOverlay.cpp
+ LoopParametersDialog.cpp
+ MyFrame.cpp
+ MyListCtrl.cpp
+ MyPanel.cpp
+ MySound.cpp
+ PitchDialog.cpp
+ StopHarmonicDialog.cpp
+ WaveformDrawer.cpp
+)
+
+pkgver() {
+ cd "$srcdir/${pkgname%-*}"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-*}"
+
+ patch -p1 -N -r - -i "$srcdir"/loopauditioneer-datadir.diff || true
}
-build(){
- cd "$srcdir/${pkgname%-*}/lib-src/libsndfile"
- aclocal
- automake
- chmod +x configure
- ./configure --disable-external-libs
- make
- cd ..
- ln -sf libsndfile/src/.libs/libsndfile.a .
- cd rtaudio
- ./configure --with-alsa
- make
- cd ..
- ln -sf rtaudio/.libs/librtaudio.a .
- cd ../src
- g++ -D__UNIX_JACK__ -D__LINUX_ALSA__ -o LoopAuditioneer LoopAuditioneer.cpp \
- MyFrame.cpp MyPanel.cpp CueMarkers.cpp LoopMarkers.cpp FileHandling.cpp MySound.cpp \
- WaveformDrawer.cpp LoopParametersDialog.cpp BatchProcessDialog.cpp AutoLoopDialog.cpp \
- AutoLooping.cpp PitchDialog.cpp CrossfadeDialog.cpp LoopOverlay.cpp FFT.cpp \
- StopHarmonicDialog.cpp CutNFadeDialog.cpp MyListCtrl.cpp ListInfoDialog.cpp \
- -I../lib-src/libsndfile/src -I../lib-src/rtaudio ../lib-src/libsndfile.a \
- ../lib-src/librtaudio.a -ljack -lasound -lpthread -lm `wx-config --cxxflags --unicode=yes --libs`
- strip --strip-all LoopAuditioneer
+build() {
+ cd "$srcdir/${pkgname%-*}"
+
+ echo "Building libsndfile..."
+ (
+ cd lib-src/libsndfile;
+ aclocal;
+ automake;
+ ./configure \
+ --disable-external-libs \
+ --enable-static;
+ make
+ )
+
+ ln -sf libsndfile/src/.libs/libsndfile.a lib-src
+ echo "Building LoopAuditioneer..."
+ (
+ cd src
+ g++ \
+ -DDATADIR=\"/usr/share/loopauditioneer\" \
+ -o LoopAuditioneer \
+ ${_cpp_sources[*]} \
+ -I../lib-src/libsndfile/src \
+ ../lib-src/libsndfile.a \
+ `pkg-config --cflags --libs rtaudio` \
+ -lm \
+ -lpthread \
+ `wx-config-gtk3 --cxxflags --unicode=yes --libs` \
+ )
}
package() {
- cd "$srcdir"
- install -Dm755 "${pkgname%-*}.sh" "$pkgdir/usr/bin/${pkgname%-*}"
- install -Dm644 "${pkgname%-*}.desktop" "$pkgdir/usr/share/applications/${pkgname%-*}.desktop"
- cd "$srcdir/${pkgname%-*}"
- install -Dm755 src/LoopAuditioneer "$pkgdir/opt/${pkgname%-*}/bin/LoopAuditioneer"
- install -dm755 src/icons "$pkgdir/opt/${pkgname%-*}/bin/icons"
- install -Dm755 src/icons/* "$pkgdir/opt/${pkgname%-*}/bin/icons/"
- install -dm755 src/help "$pkgdir/opt/${pkgname%-*}/bin/help"
- for i in $(ls src/help | grep -v images)
- do
- install -Dm755 src/help/$i "$pkgdir/opt/${pkgname%-*}/bin/help/$i"
- done
- install -dm755 src/help/images "$pkgdir/opt/${pkgname%-*}/bin/help/images"
- install -Dm755 src/help/images/* "$pkgdir/opt/${pkgname%-*}/bin/help/images/"
- install -dm755 icons "$pkgdir/opt/${pkgname%-*}/icons"
- install -Dm755 icons/index.url "$pkgdir/opt/${pkgname%-*}/icons/index.url"
- install -Dm755 icons/readme.txt "$pkgdir/opt/${pkgname%-*}/icons/index.readme"
- install -dm755 icons/24x24 "$pkgdir/opt/${pkgname%-*}/icons/24x24"
- install -Dm755 icons/24x24/* "$pkgdir/opt/${pkgname%-*}/icons/24x24/"
- mkdir -p "$pkgdir/usr/share/pixmaps"
- cd "$pkgdir/usr/share/pixmaps"
- ln -s "../../../opt/${pkgname%-*}/bin/icons/LoopyIcon-48.png" "${pkgname%-*}.png"
- cd "$srcdir/${pkgname%-*}"
- install -Dm644 README.txt "$pkgdir/usr/share/doc/${pkgname%-*}/README"
+ cd "$srcdir/${pkgname%-*}"
+ # binary
+ install -Dm755 src/LoopAuditioneer "$pkgdir/usr/bin/${pkgname%-*}"
+ # desktop file
+ install -Dm644 "${srcdir}/${pkgname%-*}.desktop" -t "$pkgdir/usr/share/applications"
+ # icons
+ install -Dm644 src/icons/*.png icons/index.url -t "$pkgdir/usr/share/${pkgname%-*}/icons"
+ install -Dm755 icons/24x24/* -t "$pkgdir/usr/share/${pkgname%-*}/icons/24x24"
+ install -Dm644 src/help/help.zip -t "$pkgdir/usr/share/${pkgname%-*}/help"
+ #install -Dm644 src/help/images/* -t "$pkgdir/usr/share/${pkgname%-*}/help/images/"
+ # application icon
+ install -dm755 "$pkgdir/usr/share/pixmaps"
+ ln -sf "../../${pkgname%-*}/icons/LoopyIcon-48.png" "$pkgdir/usr/share/pixmaps/${pkgname%-*}.png"
+ # documentation
+ install -Dm644 README.txt -t "$pkgdir/usr/share/doc/${pkgname}"
+ # icons license
+ install -Dm755 icons/readme.txt "$pkgdir/share/licenses/${pkgname}/license-icons.txt"
}
diff --git a/loopauditioneer-datadir.diff b/loopauditioneer-datadir.diff
new file mode 100644
index 000000000000..a98582ce7fb3
--- /dev/null
+++ b/loopauditioneer-datadir.diff
@@ -0,0 +1,68 @@
+diff --git a/src/LoopAuditioneer.cpp b/src/LoopAuditioneer.cpp
+index ed2832a..ea1a855 100644
+--- a/src/LoopAuditioneer.cpp
++++ b/src/LoopAuditioneer.cpp
+@@ -41,13 +41,13 @@ bool LoopAuditioneerApp::OnInit() {
+ wxImage::AddHandler(new wxJPEGHandler);
+ wxFileSystem::AddHandler(new wxZipFSHandler);
+ m_helpController = new wxHtmlHelpController();
+- m_helpController->Initialize(wxT("help/help.zip"));
++ m_helpController->Initialize(wxT(DATADIR "/help/help.zip"));
+
+ // load icons
+- m_icons = wxIconBundle(wxIcon(wxT("icons/LoopyIcon-16.png"), wxBITMAP_TYPE_PNG));
+- m_icons.AddIcon(wxIcon(wxT("icons/LoopyIcon-24.png"), wxBITMAP_TYPE_PNG));
+- m_icons.AddIcon(wxIcon(wxT("icons/LoopyIcon-32.png"), wxBITMAP_TYPE_PNG));
+- m_icons.AddIcon(wxIcon(wxT("icons/LoopyIcon-48.png"), wxBITMAP_TYPE_PNG));
++ m_icons = wxIconBundle(wxIcon(wxT(DATADIR "/icons/LoopyIcon-16.png"), wxBITMAP_TYPE_PNG));
++ m_icons.AddIcon(wxIcon(wxT(DATADIR "/icons/LoopyIcon-24.png"), wxBITMAP_TYPE_PNG));
++ m_icons.AddIcon(wxIcon(wxT(DATADIR "/icons/LoopyIcon-32.png"), wxBITMAP_TYPE_PNG));
++ m_icons.AddIcon(wxIcon(wxT(DATADIR "/icons/LoopyIcon-48.png"), wxBITMAP_TYPE_PNG));
+
+ frame->SetIcons(m_icons);
+
+diff --git a/src/MyFrame.cpp b/src/MyFrame.cpp
+index 5e2f8c0..902d308 100644
+--- a/src/MyFrame.cpp
++++ b/src/MyFrame.cpp
+@@ -680,23 +680,23 @@ MyFrame::MyFrame(const wxString& title) : wxFrame(NULL, wxID_ANY, title), m_time
+ toolBar = CreateToolBar(wxNO_BORDER | wxTB_HORIZONTAL | wxTB_FLAT);
+ toolBar->SetToolBitmapSize(wxSize(24, 24));
+ wxImage::AddHandler(new wxPNGHandler);
+- wxBitmap selectFolder(wxT("../icons/24x24/Open_folder.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap openSelectedFile(wxT("../icons/24x24/Open_file.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap saveFile(wxT("../icons/24x24/Save.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap saveFileAs(wxT("../icons/24x24/Save_as.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap startPlayback(wxT("../icons/24x24/Right.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap stopPlayback(wxT("../icons/24x24/Stop.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap loopCreation(wxT("../icons/24x24/Refresh.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap autoLoop(wxT("../icons/24x24/Search.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap autoLoopSettings(wxT("../icons/24x24/Yin-Yang.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap batchProcess(wxT("../icons/24x24/Gear.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap pitchInfo(wxT("../icons/24x24/Bell.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap zoomInAmp(wxT("../icons/24x24/Zoom_in.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap zoomOutAmp(wxT("../icons/24x24/Zoom_out.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap crossfade(wxT("../icons/24x24/Wizard.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap cutfade(wxT("../icons/24x24/Software.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap viewloop(wxT("../icons/24x24/Diagram.png"), wxBITMAP_TYPE_PNG);
+- wxBitmap listInfo(wxT("../icons/24x24/Text.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap selectFolder(wxT(DATADIR "/icons/24x24/Open_folder.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap openSelectedFile(wxT(DATADIR "/icons/24x24/Open_file.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap saveFile(wxT(DATADIR "/icons/24x24/Save.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap saveFileAs(wxT(DATADIR "/icons/24x24/Save_as.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap startPlayback(wxT(DATADIR "/icons/24x24/Right.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap stopPlayback(wxT(DATADIR "/icons/24x24/Stop.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap loopCreation(wxT(DATADIR "/icons/24x24/Refresh.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap autoLoop(wxT(DATADIR "/icons/24x24/Search.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap autoLoopSettings(wxT(DATADIR "/icons/24x24/Yin-Yang.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap batchProcess(wxT(DATADIR "/icons/24x24/Gear.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap pitchInfo(wxT(DATADIR "/icons/24x24/Bell.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap zoomInAmp(wxT(DATADIR "/icons/24x24/Zoom_in.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap zoomOutAmp(wxT(DATADIR "/icons/24x24/Zoom_out.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap crossfade(wxT(DATADIR "/icons/24x24/Wizard.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap cutfade(wxT(DATADIR "/icons/24x24/Software.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap viewloop(wxT(DATADIR "/icons/24x24/Diagram.png"), wxBITMAP_TYPE_PNG);
++ wxBitmap listInfo(wxT(DATADIR "/icons/24x24/Text.png"), wxBITMAP_TYPE_PNG);
+ toolBar->AddTool(FILE_SELECT, wxT("Select working folder"), selectFolder, wxT("Select working folder"));
+ toolBar->AddTool(OPEN_SELECTED, wxT("Open selected file"), openSelectedFile, wxT("Open selected file"));
+ toolBar->AddTool(wxID_SAVE, wxT("Save file"), saveFile, wxT("Save file"));
diff --git a/loopauditioneer.sh b/loopauditioneer.sh
deleted file mode 100755
index 16a6bac8e2ab..000000000000
--- a/loopauditioneer.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-cd /opt/loopauditioneer/bin
-exec ./LoopAuditioneer
-