summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Rys2022-11-15 23:50:18 +0100
committerMartin Rys2022-11-15 23:50:18 +0100
commit0af9f723d3bfef5af74926094a8079775838f1ed (patch)
tree088404c8b95bb4492dd103a731b253b06ea7e01b
parentdffefa867cfbc033c5b73264ed05b74237f77000 (diff)
downloadaur-0af9f723d3bfef5af74926094a8079775838f1ed.tar.gz
Remove yarn build line and dependency, app moved to Qt
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 408fc0479cde..c759c978b445 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = loot
pkgdesc = A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games.
pkgver = 0.18.6
- pkgrel = 3
+ pkgrel = 4
url = https://loot.github.io
arch = x86_64
license = GPL3
@@ -9,7 +9,6 @@ pkgbase = loot
makedepends = cmake
makedepends = rust
makedepends = cbindgen
- makedepends = yarn
makedepends = boost
depends = boost-libs
depends = libssh2
diff --git a/PKGBUILD b/PKGBUILD
index d15d7f3bca88..85d0dd803e08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=loot
pkgver=0.18.6
_pkglibver=0.18.2
-pkgrel=3
+pkgrel=4
pkgdesc="A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games."
arch=('x86_64')
url="https://loot.github.io"
license=('GPL3')
depends=('boost-libs' 'libssh2' 'alsa-lib' 'nss' 'pango' 'atk' 'libxdamage' 'libxcomposite' 'libxcursor' 'libxrandr' 'libxss' 'libxtst' 'qt5-base')
-makedepends=('git' 'cmake' 'rust' 'cbindgen' 'yarn' 'boost')
+makedepends=('git' 'cmake' 'rust' 'cbindgen' 'boost')
source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
"lib$pkgname-$_pkglibver.tar.gz::https://github.com/$pkgname/lib$pkgname/archive/$_pkglibver.tar.gz"
'LOOT.desktop'
@@ -23,7 +23,6 @@ sha256sums=('a93a5df1e34f3f54ec6023971433527776db6f8861be48e620e0f8c6a06169c5'
build() {
# libloot
cd "$srcdir/lib$pkgname-$_pkglibver"
- yarn install
mkdir -p build
cd build
cmake .. -DCMAKE_SKIP_RPATH=TRUE