summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Rys2021-04-07 18:46:02 +0200
committerMartin Rys2021-04-07 18:46:02 +0200
commit61e37e17b093eb193c67d6d4d506dab1ebb54437 (patch)
tree8f97d3036d813eea8b5488e3a89d360ff1c71247
parent7615c25244875049aae2f6926693c186155655ef (diff)
downloadaur-61e37e17b093eb193c67d6d4d506dab1ebb54437.tar.gz
add a desktop entry
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--LOOT.desktop9
-rw-r--r--PKGBUILD9
4 files changed, 21 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96007749edf7..6b7977b62c73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = loot
pkgdesc = A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games.
pkgver = 0.16.0
- pkgrel = 2
+ pkgrel = 3
url = https://loot.github.io
arch = x86_64
license = GPL3
@@ -26,8 +26,10 @@ pkgbase = loot
depends = libxtst
source = loot-0.16.0.tar.gz::https://github.com/loot/loot/archive/0.16.0.tar.gz
source = libloot-0.16.2.tar.gz::https://github.com/loot/libloot/archive/0.16.2.tar.gz
+ source = LOOT.desktop
sha256sums = b501d73e9bc00e86dc6d14b8c5f5b96effaa7c7dca654e1768c6eabdd36b887d
sha256sums = 13d815ab3aaf90c58135932d7fa5f40e44c190ab63e756f0a953ee44800ed197
+ sha256sums = 3dd063fdbe33dc82a4298bd5bcd3b4e7490adab4128389c153d12c6b074b27fb
pkgname = loot
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..a9f460abced0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!.SRCINFO
!PKGBUILD
+!LOOT.desktop
diff --git a/LOOT.desktop b/LOOT.desktop
new file mode 100644
index 000000000000..7f4005e0e852
--- /dev/null
+++ b/LOOT.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=LOOT
+Comment=LOOT
+Exec=/opt/loot/LOOT
+Terminal=false
+Type=Application
+Icon=loot
+StartupWMClass=LOOT
+Categories=Game;Utility;
diff --git a/PKGBUILD b/PKGBUILD
index 1e9e0466f6d8..f608494ed107 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=loot
# Remove spotify hax on next version bump!
pkgver=0.16.0
_pkglibver=0.16.2
-pkgrel=2
+pkgrel=3
pkgdesc="A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games."
arch=('x86_64')
url="https://loot.github.io"
@@ -13,9 +13,11 @@ depends=('boost-libs' 'http-parser' 'libssh2' 'alsa-lib' 'nss' 'pango' 'atk' 'li
makedepends=('git' 'cmake' 'rust' 'cbindgen' 'yarn' 'boost')
source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
"lib$pkgname-$_pkglibver.tar.gz::https://github.com/$pkgname/lib$pkgname/archive/$_pkglibver.tar.gz"
+ 'LOOT.desktop'
)
sha256sums=('b501d73e9bc00e86dc6d14b8c5f5b96effaa7c7dca654e1768c6eabdd36b887d'
'13d815ab3aaf90c58135932d7fa5f40e44c190ab63e756f0a953ee44800ed197'
+ '3dd063fdbe33dc82a4298bd5bcd3b4e7490adab4128389c153d12c6b074b27fb'
)
#prepare() {
@@ -74,4 +76,9 @@ package() {
mkdir -p "$pkgdir/usr/bin"
ln -s "/opt/$pkgname/LOOT" "$pkgdir/usr/bin"
+
+ # Install the icon
+ install -Dm644 "${_builddir}/../resources/icon.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/loot.svg"
+ # Install desktop entry
+ install -Dm644 ${srcdir}/../LOOT.desktop ${pkgdir}/usr/share/applications/LOOT.desktop
}