summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Rys2021-04-05 11:15:46 +0200
committerMartin Rys2021-04-05 11:15:46 +0200
commit7615c25244875049aae2f6926693c186155655ef (patch)
treef6075a7224def7cd94e1e044cb938b79edeba568
parent1b0abf19366feec76f7c6f8a8339edf6eb1dbc9e (diff)
downloadaur-7615c25244875049aae2f6926693c186155655ef.tar.gz
Disable update check
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 408325ba9a8f..96007749edf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = loot
pkgdesc = A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games.
pkgver = 0.16.0
- pkgrel = 1
+ pkgrel = 2
url = https://loot.github.io
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 8cf18e268d39..1e9e0466f6d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=loot
# Remove spotify hax on next version bump!
pkgver=0.16.0
_pkglibver=0.16.2
-pkgrel=1
+pkgrel=2
pkgdesc="A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games."
arch=('x86_64')
url="https://loot.github.io"
@@ -40,7 +40,9 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
yarn install
# Spotify Hax because of domain change
- sed -i s,opensource.spotify.com/cefbuilds,cef-builds.spotifycdn.com,g CMakeLists.txt
+ sed -i 's,opensource.spotify.com/cefbuilds,cef-builds.spotifycdn.com,g' CMakeLists.txt
+ # Cripple update check, always return no update available
+ echo 'export default async function updateExists(currentVersion: string, currentBuild: string){if(currentVersion === undefined || currentBuild === undefined || true) {return false;}}' > src/gui/html/js/updateExists.ts
mkdir -p build
cd build
cmake .. -DLIBLOOT_URL="$srcdir/lib$pkgname-$_pkglibver/build/lib$pkgname-$_pkglibver.tar.gz" \