summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadu Potop2022-12-17 13:34:27 +0000
committerRadu Potop2022-12-17 13:34:27 +0000
commit7bdf752d7e057dd41f358649ae021c709054c182 (patch)
treebd41aece68561f7a24bfaed2ef07321312f10812
parent7d488ad9e24e854abd77af39ad092e7f86fb6d23 (diff)
downloadaur-7bdf752d7e057dd41f358649ae021c709054c182.tar.gz
Package the release instead of git
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78554575944a..4986fb7fd83d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
-pkgbase = lora-font-git
- pkgdesc = Contemporary serif font that supports Latin and Cyrillic scripts. Includes OTF, TTF and variable.
- pkgver = 3.001
+pkgbase = lora-cyrillic-font
+ pkgdesc = Contemporary serif font that supports Latin and Cyrillic scripts. Includes OTF, TTF, Variable and Webfonts.
+ pkgver = 3.003
pkgrel = 1
url = https://github.com/cyrealtype/Lora-Cyrillic
arch = any
license = OFL
- source = git+https://github.com/cyrealtype/Lora-Cyrillic.git
- sha256sums = SKIP
+ source = https://github.com/cyrealtype/Lora-Cyrillic/releases/download/v3.003/Lora-v3.003.zip
+ sha256sums = a57f214f5980c86bd5f2799eaf554a0b5503c30981e013d2f7840704f80b5b76
-pkgname = lora-font-git
+pkgname = lora-cyrillic-font
diff --git a/PKGBUILD b/PKGBUILD
index 66f18d6460aa..c44db995875c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
# $Id$
# Maintainer: Radu Potop <radu at wooptoo dot com>
-pkgname=lora-font-git
-pkgver=3.001
+pkgname=lora-cyrillic-font
+pkgver=3.003
pkgrel=1
-pkgdesc='Contemporary serif font that supports Latin and Cyrillic scripts. Includes OTF, TTF and variable.'
+pkgdesc='Contemporary serif font that supports Latin and Cyrillic scripts. Includes OTF, TTF, Variable and Webfonts.'
arch=('any')
url="https://github.com/cyrealtype/Lora-Cyrillic"
license=('OFL')
source=(
- "git+${url}.git"
-)
-sha256sums=(
- 'SKIP'
+ "${url}/releases/download/v${pkgver}/Lora-v${pkgver}.zip"
)
package() {
- cd "${srcdir}/Lora-Cyrillic"
mkdir -p "${pkgdir}/usr/share/fonts/OTF/"
mkdir -p "${pkgdir}/usr/share/fonts/TTF/"
mkdir -p "${pkgdir}/usr/share/fonts/Variable/"
- install -Dm644 fonts/otf/* "${pkgdir}/usr/share/fonts/OTF/"
- install -Dm644 fonts/ttf/* "${pkgdir}/usr/share/fonts/TTF/"
- install -Dm644 fonts/variable/* "${pkgdir}/usr/share/fonts/Variable/"
+ mkdir -p "${pkgdir}/usr/share/fonts/Webfonts/"
+ cd "${srcdir}"
+ install -Dm644 otf/* "${pkgdir}/usr/share/fonts/OTF/"
+ install -Dm644 ttf/* "${pkgdir}/usr/share/fonts/TTF/"
+ install -Dm644 variable/* "${pkgdir}/usr/share/fonts/Variable/"
+ install -Dm644 webfonts/* "${pkgdir}/usr/share/fonts/Webfonts/"
}
+
+sha256sums=('a57f214f5980c86bd5f2799eaf554a0b5503c30981e013d2f7840704f80b5b76')