summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortoluschr2019-04-13 20:15:22 +0200
committertoluschr2019-04-13 20:15:22 +0200
commit558bfd1bed538bae2aa7c9ca803d7e98be0be6dc (patch)
tree276a96c1f57f6ba6b9ae167a8aa189ec96818f2c
downloadaur-558bfd1bed538bae2aa7c9ca803d7e98be0be6dc.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
-rw-r--r--lospec-editor-nativefier.desktop8
-rw-r--r--lospec-editor-nativefier.pngbin0 -> 180 bytes
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5403dee1b955
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lospec-editor-nativefier
+ pkgdesc = The Lospec Pixel Editor is a free, easy to use tool for creating pixel art
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://lospec.com/pixel-editor/app
+ arch = x86_64
+ license = MIT
+ makedepends = nodejs
+ makedepends = npm
+ makedepends = nodejs-nativefier
+ source = lospec-editor-nativefier.png
+ source = lospec-editor-nativefier.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = lospec-editor-nativefier
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..900fe0f4ecb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname="lospec-editor-nativefier"
+pkgver="0.1"
+pkgrel="1"
+pkgdesc="The Lospec Pixel Editor is a free, easy to use tool for creating pixel art"
+arch=("x86_64")
+license=("MIT")
+url="https://lospec.com/pixel-editor/app"
+makedepends=("nodejs" "npm" "nodejs-nativefier")
+
+source=("${pkgname}.png" "${pkgname}.desktop")
+sha256sums=("SKIP" "SKIP")
+
+build() {
+ cd "${srcdir}"
+
+ nativefier "https://lospec.com/pixel-editor/app" \
+ --icon "${pkgname}.png" \
+ --maximize \
+ --internal-urls ".*" \
+ --name "Lospec Pixel Editor"
+}
+
+package() {
+ install -dm755 "${pkgdir}/opt/"
+ install -dm755 "${pkgdir}/usr/bin"
+ install -dm755 "${pkgdir}/usr/share/pixmaps"
+ install -dm755 "${pkgdir}/usr/share/applications"
+
+ cp -rf "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/lospec-editor.desktop"
+ cp -rf "${srcdir}/lospec-pixel-editor-linux-x64" "${pkgdir}/opt/"
+
+ ln -sf "/opt/lospec-pixel-editor-linux-x64/microsoft-office-online" "${pkgdir}/usr/bin/lospec-pixel-editor"
+ ln -sf "/opt/lospec-pixel-editor-linux-x64/resources/app/icon.png" "${pkgdir}/usr/share/pixmaps/lospec-pixel-editor.png"
+
+ chmod 777 "${pkgdir}/opt/lospec-pixel-editor-linux-x64/resources/app/nativefier.json"
+}
+
diff --git a/lospec-editor-nativefier.desktop b/lospec-editor-nativefier.desktop
new file mode 100644
index 000000000000..f386a4958e82
--- /dev/null
+++ b/lospec-editor-nativefier.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Lospec Pixel Editor
+Comment=The Lospec Pixel Editor is a free, easy to use tool for creating pixel art
+Exec=lospec-pixel-editor
+Icon=lospec-pixel-editor
+Terminal=false
+Categories=Art;Creativity;Drawing;Development \ No newline at end of file
diff --git a/lospec-editor-nativefier.png b/lospec-editor-nativefier.png
new file mode 100644
index 000000000000..95947540b70b
--- /dev/null
+++ b/lospec-editor-nativefier.png
Binary files differ