summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2020-02-23 21:36:55 -0500
committerDavid Parrish2020-02-23 21:39:46 -0500
commit12d0a1fc0f7f532cb6ff7d2d6d73916d04e808ca (patch)
tree4d1d5312944d4944eabf919f444743b4f9c55ba0
parentf8c05edadf8a3419d6d982935f02f28fea2b050b (diff)
downloadaur-12d0a1fc0f7f532cb6ff7d2d6d73916d04e808ca.tar.gz
Update to version 3.8.0 and clean up a little bit
- Add LICENSE - Add some shellcheck suggestions - Change mantainer - Use gtk3
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD35
3 files changed, 49 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25328e2f9e52..c0b122f45c42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = losslesscut
pkgdesc = Crossplatform GUI tool for lossless trimming/cutting of video/audio files
- pkgver = 2.6.2
- pkgrel = 2
+ pkgver = 3.8.0
+ pkgrel = 1
url = https://github.com/mifi/lossless-cut
arch = x86_64
license = MIT
makedepends = asar
- depends = ffmpeg
- depends = gtk2
depends = nss
- source_x86_64 = losslesscut_2.6.2.zip::https://github.com/mifi/lossless-cut/releases/download/v2.6.2/lossless-cut-2.6.2.tar.bz2
+ depends = ffmpeg
+ depends = gtk3
+ source_x86_64 = https://github.com/mifi/lossless-cut/releases/download/v3.8.0/LosslessCut-linux.tar.bz2
source_x86_64 = losslesscut.desktop
- md5sums_x86_64 = bd109224c3eee4a815509b592c10957f
- md5sums_x86_64 = 460a126a50892d91bdc53de7fa3bc182
+ source_x86_64 = LICENSE
+ sha256sums_x86_64 = 3eca17b7f405b514bed928882429a2656dfc987f1001b2962401985633f80f5c
+ sha256sums_x86_64 = e91017634fe1e3685a6affd8d72c1ec11af4d390c9fc13d503ae67e8c6e4e852
+ sha256sums_x86_64 = 48affed7162fc2e76f1cd47b50355181b869b4025ff04c2a53b03854e329dca0
pkgname = losslesscut
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..692b5e2fa047
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2017 Mikael Finstad
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 692895410fff..512feda16ffa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,31 @@
-# Maintainer: Jose Riha <jose1711 gmail com>
-# Contributor: filthyAUR
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+
+# shellcheck disable=SC2034,SC2164
pkgname=losslesscut
-pkgver=2.6.2
-pkgrel=2
+pkgver=3.8.0
+pkgrel=1
pkgdesc="Crossplatform GUI tool for lossless trimming/cutting of video/audio files"
arch=('x86_64')
url="https://github.com/mifi/lossless-cut"
license=('MIT')
-depends=('ffmpeg' 'gtk2' 'nss')
+depends=('nss' 'ffmpeg' 'gtk3')
makedepends=('asar')
-source_x86_64=(losslesscut_${pkgver}.zip::"https://github.com/mifi/lossless-cut/releases/download/v2.6.2/lossless-cut-2.6.2.tar.bz2" "losslesscut.desktop")
+source_x86_64=("https://github.com/mifi/lossless-cut/releases/download/v$pkgver/LosslessCut-linux.tar.bz2"
+ "losslesscut.desktop"
+ "LICENSE")
+sha256sums_x86_64=('3eca17b7f405b514bed928882429a2656dfc987f1001b2962401985633f80f5c'
+ 'e91017634fe1e3685a6affd8d72c1ec11af4d390c9fc13d503ae67e8c6e4e852'
+ '48affed7162fc2e76f1cd47b50355181b869b4025ff04c2a53b03854e329dca0')
-package()
-{
- cd "$srcdir"
- mkdir -p $pkgdir/usr/{share/losslesscut,bin}
- cd lossless-cut-${pkgver}
+package() {
+ cd "${srcdir:?}"
+ mkdir -p "${pkgdir:?}"/usr/{share/losslesscut,bin}
+ cd LosslessCut-linux
asar ef resources/app.asar build/icon.svg
tar -cf - --exclude app.asar.unpacked --exclude icon.svg . | tar -C "$pkgdir/usr/share/losslesscut" -xvf -
- ln -s /usr/share/losslesscut/lossless-cut $pkgdir/usr/bin/losslesscut
+ ln -s /usr/share/losslesscut/lossless-cut "$pkgdir"/usr/bin/losslesscut
install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
install -Dm644 icon.svg "$pkgdir"/usr/share/pixmaps/$pkgname.svg
- }
-
-md5sums_x86_64=('bd109224c3eee4a815509b592c10957f'
- '460a126a50892d91bdc53de7fa3bc182')
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}