summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-01-10 04:11:08 -0800
committerxiota2023-01-10 04:13:15 -0800
commit31218abc6ebebb388a63584654b62926bc1b4148 (patch)
tree525086ba40efbf63a11bec952c584e32916d1f0c
parente68c8ecbfb1efc23d0bf25076bdc2f2bfe6e58b5 (diff)
downloadaur-31218abc6ebebb388a63584654b62926bc1b4148.tar.gz
remove unnecessary builddepends (python)
patch Makefile to respect existing LDFLAGS
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--makefile-ldflags.diff11
3 files changed, 16 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 759ee51dff0e..e786ed167980 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,11 +9,12 @@ pkgbase = lossywav-git
arch = armv7h
license = GPL
makedepends = git
- makedepends = python
depends = gcc-libs
provides = lossywav
conflicts = lossywav
source = lossywav::git+https://github.com/Sound-Linux-More/lossywav-for-linux
+ source = makefile-ldflags.diff
md5sums = SKIP
+ md5sums = 65713062cfd510acfcd06ce5ee4b503c
pkgname = lossywav-git
diff --git a/PKGBUILD b/PKGBUILD
index 006cdf7faee4..363277c31fa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,16 @@ _url_posix_old="https://github.com/MoSal/lossywav-for-posix"
url="https://github.com/Sound-Linux-More/lossywav-for-linux"
license=('GPL')
depends=(gcc-libs)
-makedepends=('git' 'python')
+makedepends=('git')
provides=("$_pkgname")
conflicts=(${provides[@]})
source=(
"$_pkgname::git+$url"
+ makefile-ldflags.diff
)
md5sums=(
'SKIP'
+ '65713062cfd510acfcd06ce5ee4b503c'
)
pkgver() {
diff --git a/makefile-ldflags.diff b/makefile-ldflags.diff
new file mode 100644
index 000000000000..d3596ad0f84e
--- /dev/null
+++ b/makefile-ldflags.diff
@@ -0,0 +1,11 @@
+--- old/Makefile
++++ new/Makefile
+@@ -5,7 +5,7 @@
+ COMMON_CXXFLAGS = -std=c++11 -O2 -pipe
+ DEFINES = -DHAVE_STD_CHRONO_STEADY_CLOCK_NOW -DHAVE_SETPRIORITY -DHAVE_STAT -DHAVE_CHMOD -DHAVE_NANOSLEEP
+ AR = ar
+-LDFLAGS = -s
++LDFLAGS += -s
+
+ CXXFLAGS = ${COMMON_CXXFLAGS} ${DEFINES}
+ ifneq ($(shell uname -m), i386)