summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-01-10 04:04:39 -0800
committerxiota2023-01-10 04:04:39 -0800
commite68c8ecbfb1efc23d0bf25076bdc2f2bfe6e58b5 (patch)
treefd55242e8d25ea10c620bb46970d5c0329767ae7
parente829afe8888fa0655550f3eec5946dced0352cc3 (diff)
downloadaur-e68c8ecbfb1efc23d0bf25076bdc2f2bfe6e58b5.tar.gz
switch to buildable fork
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 32 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0703a2170899..759ee51dff0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Sun Dec 25 21:54:08 UTC 2016
pkgbase = lossywav-git
- pkgdesc = An attempt to port lossyWAV to POSIX.
- pkgver = 1.4.2p.r1.r0.gd110728
+ pkgdesc = lossy audio pre-processor
+ pkgver = 1.4.2p.r1.r6.g8780b67
pkgrel = 1
- url = https://github.com/MoSal/lossywav-for-posix
+ url = https://github.com/Sound-Linux-More/lossywav-for-linux
arch = i686
arch = x86_64
arch = armv6h
@@ -12,11 +10,10 @@ pkgbase = lossywav-git
license = GPL
makedepends = git
makedepends = python
- depends = fftw
+ depends = gcc-libs
provides = lossywav
conflicts = lossywav
- source = lossywav::git+https://github.com/MoSal/lossywav-for-posix.git
+ source = lossywav::git+https://github.com/Sound-Linux-More/lossywav-for-linux
md5sums = SKIP
pkgname = lossywav-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 8ab97fcfee31..006cdf7faee4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,44 @@
-# Maintainer: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
+# Contributor: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
_pkgname=lossywav
pkgname=$_pkgname-git
-pkgver=1.4.2p.r1.r0.gd110728
+pkgver=1.4.2p.r1.r6.g8780b67
pkgrel=1
-pkgdesc="An attempt to port lossyWAV to POSIX."
+pkgdesc="lossy audio pre-processor"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-url="https://github.com/MoSal/lossywav-for-posix"
+_url_windows="https://sourceforge.net/projects/lossywav/"
+_url_posix_old="https://github.com/MoSal/lossywav-for-posix"
+url="https://github.com/Sound-Linux-More/lossywav-for-linux"
license=('GPL')
-depends=('fftw')
+depends=(gcc-libs)
makedepends=('git' 'python')
provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("$_pkgname::git+https://github.com/MoSal/lossywav-for-posix.git")
-md5sums=('SKIP')
+conflicts=(${provides[@]})
+source=(
+ "$_pkgname::git+$url"
+)
+md5sums=(
+ 'SKIP'
+)
pkgver() {
- cd "$_pkgname"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {
- cd "$_pkgname"
- ./waf configure \
- --prefix="$pkgdir/usr" \
- --enable-fftw3
+ cd "$srcdir/$_pkgname"
+ patch -Np1 -i "$srcdir/makefile-ldflags.diff"
}
build() {
- cd "$_pkgname"
- ./waf build
+ cd "$srcdir/$_pkgname"
+ make
}
package() {
- cd "$_pkgname"
- ./waf install --destdir=/
+ cd "$srcdir/$_pkgname"
+ install -Dm0755 lossywav-static "$pkgdir/usr/bin/lossywav"
+ install -Dm0644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}
# vim:set ts=2 sw=2 et: