summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-06-05 22:09:47 +0000
committerxiota2024-06-05 22:09:47 +0000
commitf9763115080ec9f333f860b9f5456a3fb60b2d8c (patch)
tree3e0a0f552f8dac446c5810561bb3906a99c344d0
parentef56b992a7f762d8028ab0e5065afae90558818c (diff)
downloadaur-f9763115080ec9f333f860b9f5456a3fb60b2d8c.tar.gz
1.4.2p.r21
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD56
2 files changed, 38 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0f8d826227b..367fb87c405c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = lossywav-git
pkgdesc = lossy audio pre-processor to improve flac encoding efficiency
- pkgver = 1.4.2p.r19.g8612808
+ pkgver = 1.4.2p.r21.g5c04ba3
pkgrel = 1
url = https://github.com/xiota/lossywav-for-posix
arch = i686
arch = x86_64
arch = armv6h
arch = armv7h
- license = GPL
+ license = GPL-3.0-or-later
makedepends = git
+ makedepends = meson
+ makedepends = ninja
depends = fftw
provides = lossywav
conflicts = lossywav
- source = lossywav::git+https://github.com/xiota/lossywav-for-posix
- md5sums = SKIP
+ source = lossywav::git+https://github.com/xiota/lossywav-for-posix.git
+ sha256sums = SKIP
pkgname = lossywav-git
diff --git a/PKGBUILD b/PKGBUILD
index 5c1d293282c5..af58d1ad105e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,46 @@
-# Contributor: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
-_pkgname=lossywav
-pkgname=$_pkgname-git
-pkgver=1.4.2p.r19.g8612808
+# Maintainer:
+# Contributor: sekret
+
+## useful links:
+# https://sourceforge.net/projects/lossywav/
+# https://github.com/MoSal/lossywav-for-posix
+
+_pkgname="lossywav"
+pkgname="$_pkgname-git"
+pkgver=1.4.2p.r21.g5c04ba3
pkgrel=1
pkgdesc="lossy audio pre-processor to improve flac encoding efficiency"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-_url_windows="https://sourceforge.net/projects/lossywav/"
-_url_posix_old="https://github.com/MoSal/lossywav-for-posix"
url="https://github.com/xiota/lossywav-for-posix"
-license=('GPL')
-depends=('fftw')
-makedepends=('git')
-provides=("$_pkgname")
-conflicts=(${provides[@]})
-source=(
- "$_pkgname::git+$url"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+license=('GPL-3.0-or-later')
+
+depends=(
+ 'fftw'
)
-md5sums=(
- 'SKIP'
+makedepends=(
+ 'git'
+ 'meson'
+ 'ninja'
)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+
+_pkgsrc="$_pkgname"
+source=("$_pkgname::git+$url.git")
+sha256sums=('SKIP')
+
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --tag --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd "$_pkgsrc"
+ git describe --tag --long --abbrev=7 \
+ | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/$_pkgname"
- make fftw-optimized
+ arch-meson build "$_pkgsrc"
+ meson compile -C build
}
package() {
- cd "$srcdir/$_pkgname"
- install -Dm0755 lossywav -t "$pkgdir/usr/bin"
+ meson install -C build --destdir "$pkgdir"
}
-
-# vim:set ts=2 sw=2 et: