summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit0d8a6672b2aeb4381dfed297481346b374f05097 (patch)
tree60f0d373543c10e00c2308b4c01d371c3eb5f159
downloadaur-0d8a6672b2aeb4381dfed297481346b374f05097.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD48
-rw-r--r--lostlabyrinth.desktop9
-rw-r--r--lostlabyrinth.install9
-rwxr-xr-xlostlabyrinth.sh4
5 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1a87008691b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = lostlabyrinth
+ pkgdesc = RPG turn based game
+ pkgver = 5.2.0
+ pkgrel = 1
+ url = http://www.lostlabyrinth.com/
+ install = lostlabyrinth.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = desktop-file-utils
+ depends = libpng
+ depends = sdl_gfx
+ depends = sdl_image
+ depends = sdl_ttf
+ depends = sdl_mixer
+ source = http://www.lostlabyrinth.com/download_5.2.0/lostlabyrinth_5.2.0.tar.gz
+ source = lostlabyrinth.desktop
+ source = lostlabyrinth.sh
+ md5sums = ef88eff10c3477ddd6aa83fbf4cc7e59
+ md5sums = 8feeeb9c84fdfcbc78875c6938e80c0c
+ md5sums = ea650ff17191f4adff8bcf7b8a2cf439
+
+pkgname = lostlabyrinth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f8303ad2d03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=lostlabyrinth
+pkgver=5.2.0
+pkgrel=1
+pkgdesc="RPG turn based game"
+arch=('i686' 'x86_64')
+url="http://www.lostlabyrinth.com/"
+license=('GPL')
+depends=('desktop-file-utils' 'libpng' 'sdl_gfx' 'sdl_image' 'sdl_ttf' 'sdl_mixer')
+install=$pkgname.install
+
+if [ "$CARCH" = x86_64 ]
+ then
+ source=(http://www.lostlabyrinth.com/download_${pkgver}/${pkgname}_${pkgver}_64x.tar.gz \
+ $pkgname.desktop \
+ $pkgname.sh)
+md5sums=('2e4f076b016d51159725c466f9b270be'
+ '8feeeb9c84fdfcbc78875c6938e80c0c'
+ 'ea650ff17191f4adff8bcf7b8a2cf439')
+ else
+ source=(http://www.lostlabyrinth.com/download_${pkgver}/${pkgname}_${pkgver}.tar.gz \
+ $pkgname.desktop \
+ $pkgname.sh)
+md5sums=('ef88eff10c3477ddd6aa83fbf4cc7e59'
+ '8feeeb9c84fdfcbc78875c6938e80c0c'
+ 'ea650ff17191f4adff8bcf7b8a2cf439')
+fi
+
+package () {
+ cd "${srcdir}"/laby_$pkgver
+
+ install -d -m777 "${pkgdir}"/usr/share/$pkgname
+ cp -av * "${pkgdir}"/usr/share/$pkgname/
+ install -D -m755 "${srcdir}"/$pkgname.sh "${pkgdir}"/usr/bin/$pkgname
+
+#fixing permissions
+ find "${pkgdir}"/usr/share/$pkgname -type f -exec chmod 664 "{}" \;
+ find "${pkgdir}"/usr/share/$pkgname -type f -exec chown root:users "{}" \;
+ chmod 755 "${pkgdir}"/usr/share/$pkgname/laby
+
+#.desktop file + icon
+ install -D -m644 "${srcdir}"/$pkgname.desktop \
+ "${pkgdir}"/usr/share/applications/$pkgname.desktop
+ install -D -m644 "${srcdir}"/laby_$pkgver/laby.xpm \
+ "${pkgdir}"/usr/share/pixmaps/$pkgname.xpm
+}
+
diff --git a/lostlabyrinth.desktop b/lostlabyrinth.desktop
new file mode 100644
index 000000000000..8167cb4bf102
--- /dev/null
+++ b/lostlabyrinth.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Lostlabyrinth
+Exec=lostlabyrinth
+Comment=RPG turn based game
+Comment[cs]=Tahová RPG hra
+Terminal=false
+Type=Application
+Categories=Game;RolePlaying;
+Icon=lostlabyrinth \ No newline at end of file
diff --git a/lostlabyrinth.install b/lostlabyrinth.install
new file mode 100644
index 000000000000..722a433ee386
--- /dev/null
+++ b/lostlabyrinth.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo -n "Updating desktop database ..."
+ update-desktop-database -q
+ echo " done."
+}
+
+post_remove() {
+ echo "=> If you will not play Lost Labyrinth in the future, remove the directory '/usr/share/lostlabyrinth'."
+}
diff --git a/lostlabyrinth.sh b/lostlabyrinth.sh
new file mode 100755
index 000000000000..a38aa5cb9aba
--- /dev/null
+++ b/lostlabyrinth.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/share/lostlabyrinth
+exec ./laby $@