summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLartza2015-07-07 14:43:19 +0300
committerLartza2015-07-07 14:43:19 +0300
commitaa8229a2ca37652778c11dffe8015901763fb35f (patch)
treeaf6802e187c4bd6166862cc74ecb15ca8468027d
downloadaur-aa8229a2ca37652778c11dffe8015901763fb35f.tar.gz
Initial import
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD35
-rw-r--r--lottanzb.install32
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3eefc05ad403
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = lottanzb
+ pkgdesc = A SABnzbd+ (Usenet binary downloader) GUI front-end written in PyGTK
+ pkgver = 0.6
+ pkgrel = 5
+ url = http://www.lottanzb.org/
+ install = lottanzb.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ depends = python2-dbus
+ depends = python2
+ depends = python2-configobj
+ depends = pygtk
+ optdepends = sabnzbd: for local downloading
+ optdepends = par2cmdline: for checking and repairing downloads
+ optdepends = python2-pyopenssl: for SSL encryption and HTTPS remote access
+ optdepends = python2-feedparser: for RSS support
+ optdepends = python2-yenc: for a significantly faster decoding of downloads
+ optdepends = unrar: for automatic extraction of downloads
+ optdepends = unzip: for automatic extraction of ZIP archives
+ optdepends = yelp: for displaying the help content
+ optdepends = intltool: for translation support
+ source = http://launchpad.net/lottanzb/0.6/0.6/+download/lottanzb-0.6.tar.gz
+ md5sums = 25dd324064332c68bc778dfa28b267dd
+ sha1sums = 2594a0f8fcad957b626d3dad4780dfbd3a198c47
+
+pkgname = lottanzb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd2df56a3a1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: ianux <ianux@free.fr>
+# Contributor: GERGE
+# Maintainer: Lari Tikkanen <lartza@wippies.com>
+pkgname=lottanzb
+pkgver=0.6
+pkgrel=5
+pkgdesc="A SABnzbd+ (Usenet binary downloader) GUI front-end written in PyGTK"
+arch=('i686' 'x86_64')
+url="http://www.lottanzb.org/"
+license=('GPL')
+depends=('python2-dbus' 'python2' 'python2-configobj' 'pygtk')
+makedepends=('intltool')
+optdepends=('sabnzbd: for local downloading'
+ 'par2cmdline: for checking and repairing downloads'
+ 'python2-pyopenssl: for SSL encryption and HTTPS remote access'
+ 'python2-feedparser: for RSS support'
+ 'python2-yenc: for a significantly faster decoding of downloads'
+ 'unrar: for automatic extraction of downloads'
+ 'unzip: for automatic extraction of ZIP archives'
+ 'yelp: for displaying the help content'
+ 'intltool: for translation support')
+source=(http://launchpad.net/lottanzb/0.6/0.6/+download/$pkgname-$pkgver.tar.gz)
+md5sums=('25dd324064332c68bc778dfa28b267dd')
+sha1sums=('2594a0f8fcad957b626d3dad4780dfbd3a198c47')
+install=${pkgname}.install
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py install --packaging-mode --root=${pkgdir} --prefix=/usr
+}
diff --git a/lottanzb.install b/lottanzb.install
new file mode 100644
index 000000000000..e1b8436cde57
--- /dev/null
+++ b/lottanzb.install
@@ -0,0 +1,32 @@
+niceinfo() {
+cat <<EOF
+>>
+>> If you want to use this for downloading to this machine,
+>> you must install sabnzbd!!!
+>>
+EOF
+}
+
+post_install() {
+ update-mime-database usr/share/mime >/dev/null
+ update-desktop-database -q >/dev/null
+ gtk-update-icon-cache -q -f -t /usr/share/icons/gnome >/dev/null
+ gtk-update-icon-cache -q -f -t /usr/share/icons/hicolor >/dev/null
+ niceinfo
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ update-mime-database usr/share/mime >/dev/null
+ update-desktop-database -q >/dev/null
+ gtk-update-icon-cache -q -f -t /usr/share/icons/gnome >/dev/null
+ gtk-update-icon-cache -q -f -t /usr/share/icons/hicolor >/dev/null
+}
+
+op=$1
+shift
+
+$op $*