summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-06-16 18:05:33 +0800
committerzxp198210052023-06-16 18:05:33 +0800
commit038beb64c1613c8ec0dc27be2384a4fe181b8d45 (patch)
tree7a25f8bc27b59e33a872b11371e2d7a38efa2780
downloadaur-038beb64c1613c8ec0dc27be2384a4fe181b8d45.tar.gz
first release
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD24
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6472da79aad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = lotti-bin
+ pkgdesc = Achieve your goals and keep your data private with Lotti. This life tracking app is designed to help you stay motivated and on track, all while keeping your personal information safe and secure. Now with on-device speech recognition.
+ pkgver = 0.9.377.2241
+ pkgrel = 1
+ url = https://github.com/AKotov-dev/lotti
+ arch = x86_64
+ license = GPL3
+ depends = pango
+ depends = gdk-pixbuf2
+ depends = jsoncpp
+ depends = gtk3
+ depends = gcc-libs
+ depends = libkeybinder3
+ depends = libsecret
+ depends = libepoxy
+ depends = cairo
+ depends = glib2
+ depends = at-spi2-core
+ depends = harfbuzz
+ depends = glibc
+ depends = sqlite
+ conflicts = lotti
+ noextract = lotti-0.9.377.2241.tar.gz
+ source = lotti-0.9.377.2241.tar.gz::https://github.com/AKotov-dev/lotti/releases/download/0.9.377.2241/linux.x64.tar.gz
+ source = lotti.png::https://raw.githubusercontent.com/matthiasn/lotti/main/assets/icon/app_icon_1024.png
+ sha256sums = 466e1a6dc8354bde39bbe5355fcf32144eea8a86438bd8c96ea83e1c07071423
+ sha256sums = 306adaeff6c8613e536db665d24cab8551b4a3774c5729492dd132dc690256c6
+
+pkgname = lotti-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7dd78b78fda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="lotti-bin"
+pkgver=0.9.377.2241
+_pkgver=0.9.377%2B2241
+pkgrel=1
+pkgdesc="Achieve your goals and keep your data private with Lotti. This life tracking app is designed to help you stay motivated and on track, all while keeping your personal information safe and secure. Now with on-device speech recognition."
+arch=('x86_64')
+url="https://github.com/AKotov-dev/lotti"
+license=('GPL3')
+depends=('pango' 'gdk-pixbuf2' 'jsoncpp' 'gtk3' 'gcc-libs' 'libkeybinder3' 'libsecret' 'libepoxy' 'cairo' 'glib2' 'at-spi2-core' 'harfbuzz' 'glibc' 'sqlite')
+conflicts=("${pkgname%-bin}")
+source=("${pkgname%-bin}-${pkgver}.tar.gz::${url}/releases/download/${pkgver}/linux.x64.tar.gz"
+ "${pkgname%-bin}.png::https://raw.githubusercontent.com/matthiasn/lotti/main/assets/icon/app_icon_1024.png")
+noextract=("${pkgname%-bin}-${pkgver}.tar.gz")
+sha256sums=('466e1a6dc8354bde39bbe5355fcf32144eea8a86438bd8c96ea83e1c07071423'
+ '306adaeff6c8613e536db665d24cab8551b4a3774c5729492dd132dc690256c6')
+
+package() {
+ install -Dm755 -d "${pkgdir}/opt/${pkgname%-bin}"
+ bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}.tar.gz" -C "${pkgdir}/opt/${pkgname%-bin}" --gname root --uname root
+ install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ gendesk -f -n --icon "${pkgname%-bin}" --categories "Utility" --name "${pkgname%-bin}" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file