summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-13 11:16:41 +0800
committerzxp198210052023-12-13 11:16:41 +0800
commit52558af88a4bb5ee8cf013e554e898a4f067408a (patch)
tree318996d098e12863aa5f5bd460cf60468aebb1c5
parent9b734bd27aed6328c54aa91af535349e997044b0 (diff)
downloadaur-52558af88a4bb5ee8cf013e554e898a4f067408a.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
-rw-r--r--lotti.sh8
3 files changed, 25 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cc4f6823e04..704f34791cf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lotti-bin
pkgdesc = Achieve your goals and keep your data private with Lotti. This life tracking app is designed to help you stay motivated and on track, all while keeping your personal information safe and secure. Now with on-device speech recognition.
pkgver = 0.9.396_2294
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/matthiasn/lotti
arch = x86_64
license = GPL3
@@ -20,8 +20,10 @@ pkgbase = lotti-bin
conflicts = lotti
noextract = lotti-0.9.396_2294.tar.gz
source = lotti-0.9.396_2294.tar.gz::https://github.com/matthiasn/lotti/releases/download/0.9.396+2294/linux.x64.tar.gz
- source = lotti.png::https://raw.githubusercontent.com/matthiasn/lotti/0.9.396+2294/assets/icon/app_icon_1024.png
+ source = lotti-0.9.396_2294.png::https://raw.githubusercontent.com/matthiasn/lotti/0.9.396+2294/assets/icon/app_icon_1024.png
+ source = lotti.sh
sha256sums = a3c3fa5ae7c8a1130d1ed71c809e6c445af9eec850537552f50aaca3c8b3b210
sha256sums = 306adaeff6c8613e536db665d24cab8551b4a3774c5729492dd132dc690256c6
+ sha256sums = 265b344a9c97f52feffb1c9fb07fee8919e31abe8e9e15aed6ccf76e3c49440c
pkgname = lotti-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2cd8dd3fa7c7..81056ca58806 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lotti-bin
pkgver=0.9.396_2294
-pkgrel=1
+pkgrel=2
pkgdesc="Achieve your goals and keep your data private with Lotti. This life tracking app is designed to help you stay motivated and on track, all while keeping your personal information safe and secure. Now with on-device speech recognition."
arch=('x86_64')
url="https://github.com/matthiasn/lotti"
@@ -23,20 +23,24 @@ depends=(
makedepends=('gendesk')
source=(
"${pkgname%-bin}-${pkgver}.tar.gz::${url}/releases/download/${pkgver//_/+}/linux.x64.tar.gz"
- "${pkgname%-bin}.png::https://raw.githubusercontent.com/matthiasn/lotti/${pkgver//_/+}/assets/icon/app_icon_1024.png"
+ "${pkgname%-bin}-${pkgver}.png::https://raw.githubusercontent.com/matthiasn/lotti/${pkgver//_/+}/assets/icon/app_icon_1024.png"
+ "${pkgname%-bin}.sh"
)
noextract=("${pkgname%-bin}-${pkgver}.tar.gz")
sha256sums=('a3c3fa5ae7c8a1130d1ed71c809e6c445af9eec850537552f50aaca3c8b3b210'
- '306adaeff6c8613e536db665d24cab8551b4a3774c5729492dd132dc690256c6')
+ '306adaeff6c8613e536db665d24cab8551b4a3774c5729492dd132dc690256c6'
+ '265b344a9c97f52feffb1c9fb07fee8919e31abe8e9e15aed6ccf76e3c49440c')
build() {
+ sed -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runappname@|${pkgname%-bin}|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
gendesk -q -f -n --categories "Utility" --name "${pkgname%-bin}" --exec "${pkgname%-bin}"
- mkdir -p "${srcdir}/${pkgname%-bin}"
- bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}.tar.gz" -C "${srcdir}/${pkgname%-bin}"
+ install -Dm755 -d "${srcdir}/opt/${pkgname%-bin}"
+ bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}.tar.gz" -C "${srcdir}/opt/${pkgname%-bin}"
}
package() {
- install -Dm755 -d "${pkgdir}/"{opt,usr/bin}
- cp -r "${srcdir}/${pkgname%-bin}" "${pkgdir}/opt"
- ln -sf "/opt/${pkgname%-bin}/${pkgname%-bin}" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ cp -r "${srcdir}/opt" "${pkgdir}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}-${pkgver}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file
diff --git a/lotti.sh b/lotti.sh
new file mode 100644
index 000000000000..793027350814
--- /dev/null
+++ b/lotti.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+set -e
+_APPDIR=/opt/@appname@
+_APPNAME=@runappname@
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+cd "${_APPDIR}"
+exec "${_APPDIR}/${_APPNAME}" \ No newline at end of file