summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-18 08:06:21 +0800
committerzxp198210052024-01-18 08:06:21 +0800
commit7edbdded9176626228e23c76deecf5859c3304c8 (patch)
treec12cefdfb22ff80dfaaeb73f0bd77d2a867c3a79
parent52558af88a4bb5ee8cf013e554e898a4f067408a (diff)
downloadaur-7edbdded9176626228e23c76deecf5859c3304c8.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--lotti.sh4
3 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 704f34791cf7..099f6b270582 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lotti-bin
pkgdesc = Achieve your goals and keep your data private with Lotti. This life tracking app is designed to help you stay motivated and on track, all while keeping your personal information safe and secure. Now with on-device speech recognition.
pkgver = 0.9.396_2294
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/matthiasn/lotti
arch = x86_64
license = GPL3
@@ -24,6 +24,6 @@ pkgbase = lotti-bin
source = lotti.sh
sha256sums = a3c3fa5ae7c8a1130d1ed71c809e6c445af9eec850537552f50aaca3c8b3b210
sha256sums = 306adaeff6c8613e536db665d24cab8551b4a3774c5729492dd132dc690256c6
- sha256sums = 265b344a9c97f52feffb1c9fb07fee8919e31abe8e9e15aed6ccf76e3c49440c
+ sha256sums = 62b4d10cc7cbb022b8a29cfba88158809b49ebcd5d161a1965dc26365258cbc1
pkgname = lotti-bin
diff --git a/PKGBUILD b/PKGBUILD
index 81056ca58806..4051153be5c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lotti-bin
+_pkgname=Lotti
pkgver=0.9.396_2294
-pkgrel=2
+pkgrel=3
pkgdesc="Achieve your goals and keep your data private with Lotti. This life tracking app is designed to help you stay motivated and on track, all while keeping your personal information safe and secure. Now with on-device speech recognition."
arch=('x86_64')
url="https://github.com/matthiasn/lotti"
@@ -20,7 +21,9 @@ depends=(
'at-spi2-core'
'harfbuzz'
)
-makedepends=('gendesk')
+makedepends=(
+ 'gendesk'
+)
source=(
"${pkgname%-bin}-${pkgver}.tar.gz::${url}/releases/download/${pkgver//_/+}/linux.x64.tar.gz"
"${pkgname%-bin}-${pkgver}.png::https://raw.githubusercontent.com/matthiasn/lotti/${pkgver//_/+}/assets/icon/app_icon_1024.png"
@@ -29,12 +32,12 @@ source=(
noextract=("${pkgname%-bin}-${pkgver}.tar.gz")
sha256sums=('a3c3fa5ae7c8a1130d1ed71c809e6c445af9eec850537552f50aaca3c8b3b210'
'306adaeff6c8613e536db665d24cab8551b4a3774c5729492dd132dc690256c6'
- '265b344a9c97f52feffb1c9fb07fee8919e31abe8e9e15aed6ccf76e3c49440c')
+ '62b4d10cc7cbb022b8a29cfba88158809b49ebcd5d161a1965dc26365258cbc1')
build() {
sed -e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runappname@|${pkgname%-bin}|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- gendesk -q -f -n --categories "Utility" --name "${pkgname%-bin}" --exec "${pkgname%-bin}"
+ gendesk -q -f -n --categories "Utility" --name "${_pkgname}" --exec "${pkgname%-bin} %U"
install -Dm755 -d "${srcdir}/opt/${pkgname%-bin}"
bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}.tar.gz" -C "${srcdir}/opt/${pkgname%-bin}"
}
diff --git a/lotti.sh b/lotti.sh
index 793027350814..4b9953cec610 100644
--- a/lotti.sh
+++ b/lotti.sh
@@ -1,8 +1,8 @@
#!/bin/sh
set -e
_APPDIR=/opt/@appname@
-_APPNAME=@runappname@
+_RUNNAME=@runname@
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/lib:${LD_LIBRARY_PATH}"
cd "${_APPDIR}"
-exec "${_APPDIR}/${_APPNAME}" \ No newline at end of file
+exec "${_RUNNAME}" "$@" || exit $? \ No newline at end of file