summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-14 17:40:52 +0800
committerzxp198210052023-09-14 17:40:52 +0800
commita35eb3edc566e5131dedde2e225b73ac54fd1caf (patch)
tree22ccc6d3e79ef321a15915e6ec2539a5f0ea1097
parent453ba222655672411fef20216aa9632da8af8854 (diff)
downloadaur-a35eb3edc566e5131dedde2e225b73ac54fd1caf.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8354489a06b0..f8e1ac259a33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = lotti-bin
pkgdesc = Achieve your goals and keep your data private with Lotti. This life tracking app is designed to help you stay motivated and on track, all while keeping your personal information safe and secure. Now with on-device speech recognition.
pkgver = 0.9.395_2291
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/matthiasn/lotti
arch = x86_64
license = GPL3
+ makedepends = gendesk
depends = pango
depends = gdk-pixbuf2
depends = jsoncpp
@@ -18,12 +19,11 @@ pkgbase = lotti-bin
depends = at-spi2-core
depends = harfbuzz
depends = glibc
- depends = sqlite
provides = lotti=0.9.395_2291
conflicts = lotti
noextract = lotti-0.9.395_2291.tar.gz
source = lotti-0.9.395_2291.tar.gz::https://github.com/matthiasn/lotti/releases/download/0.9.395+2291/linux.x64.tar.gz
- source = lotti.png::https://raw.githubusercontent.com/matthiasn/lotti/main/assets/icon/app_icon_1024.png
+ source = lotti.png::https://raw.githubusercontent.com/matthiasn/lotti/0.9.395+2291/assets/icon/app_icon_1024.png
sha256sums = 585ba9745dd626da5aa14fcb1db0ef7d71e6ed0dfb507969df01001db36eac0d
sha256sums = 306adaeff6c8613e536db665d24cab8551b4a3774c5729492dd132dc690256c6
diff --git a/PKGBUILD b/PKGBUILD
index 0ae4577e758b..bbb6d1a6a4c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,29 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lotti-bin
pkgver=0.9.395_2291
-pkgrel=2
+pkgrel=3
pkgdesc="Achieve your goals and keep your data private with Lotti. This life tracking app is designed to help you stay motivated and on track, all while keeping your personal information safe and secure. Now with on-device speech recognition."
arch=('x86_64')
url="https://github.com/matthiasn/lotti"
license=('GPL3')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('pango' 'gdk-pixbuf2' 'jsoncpp' 'gtk3' 'gcc-libs' 'libkeybinder3' 'libsecret' 'libepoxy' 'cairo' 'glib2' 'at-spi2-core' 'harfbuzz' 'glibc' 'sqlite')
+depends=('pango' 'gdk-pixbuf2' 'jsoncpp' 'gtk3' 'gcc-libs' 'libkeybinder3' 'libsecret' 'libepoxy' 'cairo' 'glib2' 'at-spi2-core' 'harfbuzz' 'glibc')
+makedepends=('gendesk')
source=("${pkgname%-bin}-${pkgver}.tar.gz::${url}/releases/download/${pkgver//_/+}/linux.x64.tar.gz"
- "${pkgname%-bin}.png::https://raw.githubusercontent.com/matthiasn/lotti/main/assets/icon/app_icon_1024.png")
+ "${pkgname%-bin}.png::https://raw.githubusercontent.com/matthiasn/lotti/${pkgver//_/+}/assets/icon/app_icon_1024.png")
noextract=("${pkgname%-bin}-${pkgver}.tar.gz")
sha256sums=('585ba9745dd626da5aa14fcb1db0ef7d71e6ed0dfb507969df01001db36eac0d'
'306adaeff6c8613e536db665d24cab8551b4a3774c5729492dd132dc690256c6')
+prepare() {
+ mkdir -p "${srcdir}/${pkgname%-bin}"
+ bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}.tar.gz" -C "${srcdir}/${pkgname%-bin}"
+ gendesk -f -n --categories "Utility" --name "${pkgname%-bin}" --exec "${pkgname%-bin}"
+}
package() {
- install -Dm755 -d "${pkgdir}/opt/${pkgname%-bin}"
- bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}.tar.gz" -C "${pkgdir}/opt/${pkgname%-bin}" --gname root --uname root
+ install -Dm755 -d "${pkgdir}/"{opt,usr/bin}
+ cp -r "${srcdir}/${pkgname%-bin}" "${pkgdir}/opt"
+ ln -sf "/opt/${pkgname%-bin}/${pkgname%-bin}" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
- gendesk -f -n --icon "${pkgname%-bin}" --categories "Utility" --name "${pkgname%-bin}" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file