summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblubbblubb2022-04-11 19:44:00 +0200
committerblubbblubb2022-04-11 19:44:00 +0200
commit1fec453d067b919954bbddce30813ded546075c4 (patch)
treeb7c47149480e6d8f4fce520016a7be88bbe32e5b
parent85141918ad2127c0c826ac354fd018f357088728 (diff)
downloadaur-1fec453d067b919954bbddce30813ded546075c4.tar.gz
add patch for ffmpeg5
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--fix_ffmpeg5.patch14
3 files changed, 27 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c18a14ae61d..5259c7add364 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = loudgain
pkgdesc = A loudness normalizer that scans music files and calculates loudness-normalized gain and loudness peak values according to the EBU R128 standard, and can optionally write ReplayGain-compatible metadata.
pkgver = v0.6.8
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Moonbase59/loudgain
arch = i686
arch = x86_64
@@ -13,7 +13,8 @@ pkgbase = loudgain
provides = loudgain
provides = rgbpm
source = loudgain-0.6.8.tar.gz::https://github.com/Moonbase59/loudgain/archive/v0.6.8.tar.gz
+ source = fix_ffmpeg5.patch
sha256sums = 1137c193ad941b366e87c5d84ccc95a7aa8571affc060db0bd1cf72c489aeaee
+ sha256sums = 73c1cc5d416e2b5b73a4deac1ef2b563d289976c296c24b39c1e8d740333d2ff
pkgname = loudgain
-
diff --git a/PKGBUILD b/PKGBUILD
index 5c0b2800b577..cd925e778e93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=loudgain
pkgver=v0.6.8
_pkgver=0.6.8
-pkgrel=2
+pkgrel=3
pkgdesc="A loudness normalizer that scans music files and calculates loudness-normalized gain and loudness peak values according to the EBU R128 standard, and can optionally write ReplayGain-compatible metadata."
url="https://github.com/Moonbase59/loudgain"
arch=('i686' 'x86_64')
@@ -11,8 +11,15 @@ license=('BSD 2-Clause "Simplified" License')
depends=("taglib" "libebur128" "ffmpeg")
makedepends=('cmake')
provides=('loudgain' 'rgbpm')
-source=("loudgain-${_pkgver}.tar.gz::https://github.com/Moonbase59/loudgain/archive/${pkgver}.tar.gz")
-sha256sums=('1137c193ad941b366e87c5d84ccc95a7aa8571affc060db0bd1cf72c489aeaee')
+source=("loudgain-${_pkgver}.tar.gz::https://github.com/Moonbase59/loudgain/archive/${pkgver}.tar.gz"
+ "fix_ffmpeg5.patch")
+sha256sums=('1137c193ad941b366e87c5d84ccc95a7aa8571affc060db0bd1cf72c489aeaee'
+ '73c1cc5d416e2b5b73a4deac1ef2b563d289976c296c24b39c1e8d740333d2ff')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${_pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/fix_ffmpeg5.patch"
+}
build() {
cd "${srcdir}/${pkgname}-${_pkgver}"
diff --git a/fix_ffmpeg5.patch b/fix_ffmpeg5.patch
new file mode 100644
index 000000000000..7b02714de797
--- /dev/null
+++ b/fix_ffmpeg5.patch
@@ -0,0 +1,14 @@
+# Source: https://github.com/Moonbase59/loudgain/pull/50#issuecomment-1050879198
+--- a/src/scan.c~ 2019-09-06 16:31:19.000000000 +0100
++++ b/src/scan.c 2022-02-25 13:33:06.186080276 +0000
+@@ -69,8 +69,9 @@ int scan_init(unsigned nb_files) {
+ * It is now useless
+ * https://github.com/FFmpeg/FFmpeg/blob/70d25268c21cbee5f08304da95be1f647c630c15/doc/APIchanges#L86
+ */
+- if (avformat_version() < AV_VERSION_INT(58,9,100))
++#if LIBAVFORMAT_VERSION_INT < AV_VERSION_INT(58,9,100)
+ av_register_all();
++#endif
+
+ av_log_set_callback(scan_av_log);
+