summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexis Jeandeau2020-11-24 09:22:22 +0900
committerAlexis Jeandeau2020-11-24 09:22:22 +0900
commitf360cc19c072da59fc67ec895a4dfefcb7c089ba (patch)
tree8f169da469a6c5011d4ee64c5d1a429bdf7fe877
downloadaur-f360cc19c072da59fc67ec895a4dfefcb7c089ba.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore29
-rw-r--r--PKGBUILD51
3 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df4f29d2bb6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = loudgain-git
+ pkgdesc = A loudness normalizer that scans music files and calculates loudness-normalized gain and loudness peak values according to the EBU R128 standard, and can optionally write ReplayGain-compatible metadata.
+ pkgver = v0.6.8.r12.g0ff67ee
+ pkgrel = 1
+ url = https://github.com/Moonbase59/loudgain
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ depends = libebur128
+ depends = ffmpeg
+ depends = python
+ depends = taglib
+ provides = loudgain
+ provides = rgbpm
+ provides = rgbpm2
+ conflicts = loudgain
+ source = git+https://github.com/Moonbase59/loudgain
+ sha256sums = SKIP
+
+pkgname = loudgain-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..70a247f4537f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,29 @@
+### ArchLinux Packages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+### Linux ###
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af180a5cccfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Alexis Jeandeau <alexis[dot]jeandeau[at]gmail[dot]com>
+
+pkgname=loudgain-git
+_gitname=loudgain
+pkgver=v0.6.8.r12.g0ff67ee
+pkgrel=1
+pkgdesc="A loudness normalizer that scans music files and calculates loudness-normalized gain and loudness peak values according to the EBU R128 standard, and can optionally write ReplayGain-compatible metadata."
+url="https://github.com/Moonbase59/loudgain"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+license=('BSD')
+depends=('libebur128'
+ 'ffmpeg'
+ 'python'
+ 'taglib')
+makedepends=('cmake'
+ 'git')
+provides=('loudgain'
+ 'rgbpm'
+ 'rgbpm2')
+conflicts=('loudgain')
+source=('git+https://github.com/Moonbase59/loudgain')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ mkdir -p "${srcdir}/build"
+}
+
+build() {
+ cd "${srcdir}/build"
+
+ cmake ../${_gitname} -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+
+ make DESTDIR="${pkgdir}/" install
+ install -Dm755 "${srcdir}/${_gitname}/bin/rgbpm" ${pkgdir}/usr/bin/
+ install -Dm755 "${srcdir}/${_gitname}/bin/rgbpm2" ${pkgdir}/usr/bin/
+ # License is BSD 2 clause type and needs to be installed
+ install -Dm644 "${srcdir}/${_gitname}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: