summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDouglas Browne2021-06-25 13:21:17 -0700
committerDouglas Browne2021-06-25 13:21:17 -0700
commite6412fbced802ec413da321afc15bdb60ae096d2 (patch)
treea3415b92d94d727dd09f582efda062ac9118053f
parent278a0645c64ddd6cd4e28e65128f73a086d9511b (diff)
downloadaur-e6412fbced802ec413da321afc15bdb60ae096d2.tar.gz
apply patch from gabor_zoka
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a62cbaa4926a..9ffdd25ecd52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Douglas Browne <douglas.browne123@gmail.com>
pkgname=loudness-scanner-git
-pkgver=v0.5.1.r18.g3d333bf
+pkgver=v0.5.1.r45.gde149a1
pkgrel=1
pkgdesc="EBU R128 loudness normalization tool"
arch=('any')
@@ -21,14 +21,12 @@ md5sums=('SKIP')
prepare() {
cd "$srcdir/$pkgname"
git submodule init
- git submodule deinit ebur128
git submodule update
- sed -i '/add_subdirectory(ebur128\/ebur128)/d' ./CMakeLists.txt
}
build() {
cd "$srcdir/$pkgname"
- cmake -DDISABLE_GTK2:BOOL=ON -DDISABLE_QT4:BOOL=ON .
+ cmake -DDISABLE_GTK2:BOOL=ON -DDISABLE_QT4:BOOL=ON -DDISABLE_QT5:BOOL=ON .
make
}
@@ -36,6 +34,9 @@ package() {
cd "$srcdir/$pkgname"
install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 755 loudness "${pkgdir}/usr/bin/loudness"
+ for i in libinput_*; do
+ install -Dm 644 "$i" "${pkgdir}/usr/lib/$i"
+ done
}
pkgver() {