summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart van Strien2020-09-12 12:08:47 +0200
committerBart van Strien2020-09-12 12:08:47 +0200
commitce063712a1060821432efb78871d62068bcd93ae (patch)
tree9ef628d4af61348e3a3dc1893d5016938262e78d
parent0072f059b461f56ac735d694fa9554a81dd0a883 (diff)
downloadaur-ce063712a1060821432efb78871d62068bcd93ae.tar.gz
Upgrade to love-git after move to github
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 810c13285e57..edf90baa611d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
-# Generated by mksrcinfo v8
-# Wed Dec 16 14:15:15 UTC 2015
-pkgbase = love-hg
+pkgbase = love-git
pkgdesc = An open-source 2D game engine which uses the versatile Lua scripting language to create dynamic gaming experiences.
- pkgver = r2651.7f6a147e5501
+ pkgver = 20200816.9f62bafe
pkgrel = 1
url = http://love2d.org/
arch = i686
arch = x86_64
license = ZLIB
- makedepends = mercurial
+ makedepends = git
depends = luajit
depends = physfs
depends = freetype2
@@ -21,9 +19,10 @@ pkgbase = love-hg
depends = libpng
depends = libjpeg-turbo
depends = libtheora
+ replaces = love-hg
options = !strip
- source = hg+https://bitbucket.org/rude/love
+ source = git+https://github.com/love2d/love
sha256sums = SKIP
-pkgname = love-hg
+pkgname = love-git
diff --git a/PKGBUILD b/PKGBUILD
index 5c7370a520f8..1f07ccc029bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Bart van Strien <bart.bes@gmail.com>
# Contributor: Linus Sjögren <thelinx@unreliablepollution.net>
# Contributor: Andrzej Giniewicz < gginiu@gmail.com >
-pkgname=love-hg
-pkgver=r2651.7f6a147e5501
+pkgname=love-git
+pkgver=20200816.9f62bafe
pkgrel=1
pkgdesc="An open-source 2D game engine which uses the versatile Lua scripting language to create dynamic gaming experiences."
arch=(i686 x86_64)
@@ -12,16 +12,15 @@ depends=(
'luajit' 'physfs' 'freetype2' 'mpg123' 'openal' 'libvorbis' 'libmodplug'
'sdl2' 'zlib' 'libpng' 'libjpeg-turbo' 'libtheora'
)
-source=('hg+https://bitbucket.org/rude/love')
-makedepends=('mercurial')
+replaces=('love-hg')
+source=('git+https://github.com/love2d/love')
+makedepends=('git')
options=(!strip)
sha256sums=('SKIP')
pgkver() {
cd $srcdir/love
-
- # As per the wiki the version is r<commit number>.<commit hash>
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
}
build() {
@@ -30,7 +29,7 @@ build() {
# Update version information in configure script
msg "Updating version information"
head -c 15 platform/unix/configure.ac > configure.ac.tmp
- echo " [`hg log -l1 --template '{node|short}'`-`date +%Y%m%d`])" >> configure.ac.tmp
+ echo " [$pkgver])" >> configure.ac.tmp
tail -n +2 platform/unix/configure.ac >> configure.ac.tmp
mv configure.ac.tmp platform/unix/configure.ac
@@ -38,9 +37,9 @@ build() {
head -n 4 platform/unix/Makefile.am > Makefile.am.tmp
mv Makefile.am.tmp platform/unix/Makefile.am
- # Generate a configure script for love-hg (note the suffix), then configure
+ # Generate a configure script for love-git (note the suffix), then configure
msg "Generating makefiles"
- sh platform/unix/automagic -hg
+ sh platform/unix/automagic -git
./configure --enable-silent-rules --prefix=/usr LDFLAGS=""
# Finally build