summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-07-05 17:13:45 +0200
committerMarcell Meszaros2022-07-05 18:26:57 +0200
commit69e1e0500ada03c6879b6e7cb0058be648549d26 (patch)
tree5e2fd31cd639c7b2a85023448c1decb2288c84c4
parent366da423087de28f61964a165907d742813f7610 (diff)
downloadaur-69e1e0500ada03c6879b6e7cb0058be648549d26.tar.gz
0.7.2-8: fix build (using lua51), remove unneeded deps, fix desktop entry
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore16
-rw-r--r--PKGBUILD48
-rw-r--r--love.desktop11
-rw-r--r--love07.desktop9
-rw-r--r--love07.install14
6 files changed, 62 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44418832a75e..77058758c194 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,40 +1,32 @@
pkgbase = love07
- pkgdesc = An open-source 2D game engine which uses the versatile Lua scripting language to create dynamic gaming experiences.
+ pkgdesc = An open-source 2D game engine using Lua scripting language (legacy 0.7.x version)
pkgver = 0.7.2
- pkgrel = 7
+ pkgrel = 8
url = http://love2d.org/
- install = love07.install
arch = i686
arch = x86_64
license = zlib
- depends = desktop-file-utils
depends = devil
depends = freetype2
depends = hicolor-icon-theme
depends = libmodplug
depends = libvorbis
- depends = luajit
+ depends = lua51
depends = mpg123
depends = openal
depends = physfs
depends = sdl
- depends = shared-mime-info
depends = libgl
depends = glu
- depends = libmng
source = https://github.com/love2d/love/releases/download/0.7.2/love-0.7.2-linux-src.tar.gz
source = https://raw.githubusercontent.com/love2d/love/0.7.2/license.txt
- source = https://raw.githubusercontent.com/love2d/love/0.7.2/platform/unix/app.svg
- source = https://raw.githubusercontent.com/love2d/love/0.7.2/platform/unix/game.svg
- source = love.desktop
+ source = love07.svg::https://raw.githubusercontent.com/love2d/love/0.7.2/platform/unix/app.svg
+ source = love07.desktop
source = love07.patch
- source = https://raw.githubusercontent.com/love2d/love/0.7.2/platform/unix/love.xml
sha256sums = a57adcb0cbdc390a9bd8e2fe477bc175799b9ffd3486e01f859a36bf27f7f268
sha256sums = c4cb43c06ab89c84349704a62849e9e66bf0c245e8a4df4f9068204124de1845
sha256sums = b8116c4cc8d7b80adba579b582b9570d8178f93d3d9e35977d621e03500b8a7f
- sha256sums = 7452bc537980d6fdd6293d8bdaedbfa68264fa9bb160503d9b1ad16c8278b6af
- sha256sums = d045b6c1aeb8fdb9ec33c75d204e0698f34e863063c274633b79e8b1b7f7a302
+ sha256sums = 8b6db85ae8098a537e1e6d04153f2ba81e3aca0f963c80a4743fece885f43ea1
sha256sums = 6b63906f9dabc9c000ddce32bec7020e89f51e88425d1eb940a533dd9b9ab09b
- sha256sums = 5b72ae3818ada71ec7fd69c2a27126dc5c759257e1ff203639655c389a24ccb1
pkgname = love07
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6696e5c62eee
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,16 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+
+*/
+*.orig
+*.bak
+*.backup
diff --git a/PKGBUILD b/PKGBUILD
index ea12ea29bf6d..d65e15becc3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,30 @@
+# Maintainer: Parker Reed <parker.l.reed@gmail.com>
+# Maintainer: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: archtux <antonio dot arias99999 at gmail dot com>
# Contributor: andy123 < ajs [at] online [dot] de >
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: Linus Sjögren <thelinx@unreliablepollution.net>
# Contributor: Eric Forgeot < http://anamnese.online.fr >, dreeze
# Contributor: SanskritFritz (gmail)
-# Maintainer: Parker Reed <parker.l.reed@gmail.com>
pkgname=love07
pkgver=0.7.2
-pkgrel=7
-pkgdesc="An open-source 2D game engine which uses the versatile Lua scripting language to create dynamic gaming experiences."
+pkgrel=8
+pkgdesc="An open-source 2D game engine using Lua scripting language (legacy 0.7.x version)"
arch=('i686' 'x86_64')
url="http://love2d.org/"
license=('zlib')
-depends=('desktop-file-utils' 'devil' 'freetype2' 'hicolor-icon-theme' 'libmodplug' 'libvorbis' 'luajit' 'mpg123' 'openal' 'physfs' 'sdl' 'shared-mime-info' 'libgl' 'glu' 'libmng')
-install=$pkgname.install
+depends=('devil' 'freetype2' 'hicolor-icon-theme' 'libmodplug' 'libvorbis' 'lua51' 'mpg123' 'openal' 'physfs' 'sdl' 'libgl' 'glu')
source=("https://github.com/love2d/love/releases/download/0.7.2/love-0.7.2-linux-src.tar.gz"
"https://raw.githubusercontent.com/love2d/love/0.7.2/license.txt"
- "https://raw.githubusercontent.com/love2d/love/0.7.2/platform/unix/app.svg"
- "https://raw.githubusercontent.com/love2d/love/0.7.2/platform/unix/game.svg"
- "love.desktop"
- "love07.patch"
- "https://raw.githubusercontent.com/love2d/love/0.7.2/platform/unix/love.xml")
+ "${pkgname}.svg::https://raw.githubusercontent.com/love2d/love/0.7.2/platform/unix/app.svg"
+ "love07.desktop"
+ "love07.patch")
sha256sums=('a57adcb0cbdc390a9bd8e2fe477bc175799b9ffd3486e01f859a36bf27f7f268'
'c4cb43c06ab89c84349704a62849e9e66bf0c245e8a4df4f9068204124de1845'
'b8116c4cc8d7b80adba579b582b9570d8178f93d3d9e35977d621e03500b8a7f'
- '7452bc537980d6fdd6293d8bdaedbfa68264fa9bb160503d9b1ad16c8278b6af'
- 'd045b6c1aeb8fdb9ec33c75d204e0698f34e863063c274633b79e8b1b7f7a302'
- '6b63906f9dabc9c000ddce32bec7020e89f51e88425d1eb940a533dd9b9ab09b'
- '5b72ae3818ada71ec7fd69c2a27126dc5c759257e1ff203639655c389a24ccb1')
+ '8b6db85ae8098a537e1e6d04153f2ba81e3aca0f963c80a4743fece885f43ea1'
+ '6b63906f9dabc9c000ddce32bec7020e89f51e88425d1eb940a533dd9b9ab09b')
prepare() {
cd "$srcdir/love-HEAD"
@@ -46,8 +42,25 @@ prepare() {
# Fix mesa 10 GLee.h(thanks to ajs124)
sed -i '70itypedef XID GLXContextID;' "src/modules/graphics/opengl/GLee.h"
-
- ./configure --prefix=/usr --enable-luajit --program-suffix=07
+
+ echo
+ echo "Editing 'configure.in': removing MNG dependency (not needed by 'devil')"
+ sed -e '/mng_initialize/d' \
+ -i 'configure.in'
+
+ echo "Regenerating autoconf scripts after changing 'configure.in'..."
+ autoreconf --verbose --force --install --symlink
+ echo
+
+ echo "Configuring the env vars for the build"
+ echo '-- Adding CPPFLAGS to CFLAGS and CXXFLAGS, otherwise the build scripts ignore the former'
+ echo '-- Adding LDFLAGS to CFLAGS and CXXFLAGS, otherwise the build scripts ignore the former'
+ export CFLAGS+=" ${CPPFLAGS} ${LDFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS} ${LDFLAGS}"
+ echo
+
+ echo "Running 'configure' script..."
+ ./configure --prefix=/usr --program-suffix=07
}
build() {
@@ -62,5 +75,6 @@ package() {
cd ..
install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 love.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$pkgname.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm644 "$pkgname.svg" -t "$pkgdir/usr/share/icons/hicolor/scalable/apps"
}
diff --git a/love.desktop b/love.desktop
deleted file mode 100644
index 5b133bc7dd69..000000000000
--- a/love.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-
-[Desktop Entry]
-Name=LÖVE
-Comment=The unquestionably awesome 2D game engine
-MimeType=application/x-love-game;
-Exec=/usr/bin/love07
-Type=Application
-Categories=Development;Game;
-Terminal=false
-Icon=love.svg
-NoDisplay=true \ No newline at end of file
diff --git a/love07.desktop b/love07.desktop
new file mode 100644
index 000000000000..84c6ae0329c5
--- /dev/null
+++ b/love07.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=LÖVE 0.7
+Comment=The unquestionably awesome 2D game engine (legacy version)
+Exec=/usr/bin/love07 %f
+Type=Application
+Categories=Development;Game;
+Terminal=false
+Icon=love07
+NoDisplay=false
diff --git a/love07.install b/love07.install
deleted file mode 100644
index 237cf1a16c38..000000000000
--- a/love07.install
+++ /dev/null
@@ -1,14 +0,0 @@
-
-post_install() {
- update-desktop-database -q
- update-mime-database usr/share/mime
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_remove() {
- post_install
-}
-
-post_upgrade() {
- post_install
-} \ No newline at end of file