summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2021-10-19 12:35:39 +0200
committerJose Riha2021-10-19 12:35:39 +0200
commit4b87ad7cb933cf518c0cfb9712bbf0503d91627e (patch)
tree206520c67ad9778f051360c0bf931940a795d887
parent4f4a127a7a8a3d741fcbddb99d48dc1703f335b6 (diff)
downloadaur-4b87ad7cb933cf518c0cfb9712bbf0503d91627e.tar.gz
Drop love conflict (thanks @pio)
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD53
2 files changed, 29 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6134ad6d565..67527b3cb1c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = love10
- pkgdesc = An open-source 2D game engine which uses the versatile Lua scripting language to create dynamic gaming experiences
+ pkgdesc = An open-source 2D game engine which uses the versatile Lua scripting language to create dynamic g aming experiences
pkgver = 0.10.2
- pkgrel = 2
+ pkgrel = 3
url = http://love2d.org/
arch = i686
arch = x86_64
@@ -16,8 +16,7 @@ pkgbase = love10
depends = libmodplug
depends = sdl2
provides = love
- conflicts = love
- source = https://github.com/love2d/love/releases/download/0.10.2/love-0.10.2-linux-src.tar.gz
- md5sums = SKIP
+ source = https://github.com/love2d/love/archive/refs/tags/0.10.2.tar.gz
+ md5sums = dae522353f40300ad30799517b4ccdc6
pkgname = love10
diff --git a/PKGBUILD b/PKGBUILD
index 7d3d8653452c..770f111b001f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,44 +2,43 @@
# Contributor: Kyle McLamb <alloyed@tfwno.gf>
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: Linus Sjögren <thelinx@unreliablepollution.net>
-# Contributor: Eric Forgeot < http://anamnese.online.fr >, dreeze
-# Contributor: bageljr
+# Contributor: Eric Forgeot < http://anamnese.online.fr >
+# Contributor: dreeze, bageljr, pio
pkgname=love10
pkgver=0.10.2
-pkgrel=2
-pkgdesc="An open-source 2D game engine which uses the versatile Lua scripting language to create dynamic gaming experiences"
+pkgrel=3
+pkgdesc="An open-source 2D game engine which uses the versatile Lua scripting language to create dynamic g
+aming experiences"
arch=(i686 x86_64)
url="http://love2d.org/"
license=('zlib')
depends=('luajit' 'physfs' 'freetype2' 'mpg123' 'openal' 'libvorbis' 'libmodplug' 'sdl2')
-source=("https://github.com/love2d/love/releases/download/0.10.2/love-0.10.2-linux-src.tar.gz")
-conflicts=('love')
+source=("https://github.com/love2d/love/archive/refs/tags/$pkgver.tar.gz")
+md5sums=('dae522353f40300ad30799517b4ccdc6')
provides=('love')
makedepends=('git')
-md5sums=('SKIP')
-build() {
- cd "$srcdir"/love-$pkgver
-
- # Update version information in configure script
- echo "Updating version information"
- head -c 15 configure.ac > configure.ac.tmp
- echo " [0.10.2])" >> configure.ac.tmp
- tail -n +2 configure.ac >> configure.ac.tmp
- mv configure.ac.tmp platform/unix/configure.ac
+prepare() {
+ cd "$srcdir/love-$pkgver/platform/unix"
- # Skip installing desktop files, icons, etc
- head -n 4 Makefile.am > Makefile.am.tmp
- mv Makefile.am.tmp platform/unix/Makefile.am
+ # Update version information in configure script
+ sed -i 1s/HEAD/$pkgver/ configure.ac
- # Generate a configure script for love-hg (note the suffix), then configure
- echo "Generating makefiles"
- #sh platform/unix/automagic 10
- ./configure --enable-silent-rules --prefix=/usr LDFLAGS=""
+ # Skip installing desktop files, icons, etc
+ sed -i 4q Makefile.am
+}
- # Finally build
- echo "Building"
- make
+build() {
+ cd "$srcdir/love-$pkgver"
+
+ # Generate a configure script, then configure
+ echo "Generating makefiles"
+ sh platform/unix/automagic 10 # this number names executable and library
+ ./configure --enable-silent-rules --prefix=/usr LDFLAGS=""
+
+ # Finally build
+ echo "Building"
+ make
}
package() {
@@ -47,5 +46,3 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm0644 "license.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: