summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle McLamb2018-04-04 21:20:31 -0400
committerKyle McLamb2018-04-04 21:20:31 -0400
commitbcbf7de93015302d3c32ba7e916f9ffa43962fc3 (patch)
tree4132723da370423bcd2b8382c81606c3185fb4b7
downloadaur-bcbf7de93015302d3c32ba7e916f9ffa43962fc3.tar.gz
Initial commit, copy from love09
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD49
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb5fc9d76904
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = love10
+ pkgdesc = An open-source 2D game engine which uses the versatile Lua scripting language to create dynamic gaming experiences
+ pkgver = 0.10.2
+ pkgrel = 1
+ url = http://love2d.org/
+ arch = i686
+ arch = x86_64
+ license = zlib
+ makedepends = mercurial
+ depends = luajit
+ depends = physfs
+ depends = freetype2
+ depends = mpg123
+ depends = openal
+ depends = libvorbis
+ depends = libmodplug
+ depends = sdl2
+ source = hg+https://bitbucket.org/rude/love#tag=0.10.2
+ md5sums = SKIP
+
+pkgname = love10
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ed2563ea771
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Kyle McLamb <alloyed@tfwno.gf>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Linus Sjögren <thelinx@unreliablepollution.net>
+# Contributor: Eric Forgeot < http://anamnese.online.fr >, dreeze
+pkgname=love10
+pkgver=0.10.2
+pkgrel=1
+pkgdesc="An open-source 2D game engine which uses the versatile Lua scripting language to create dynamic gaming experiences"
+arch=(i686 x86_64)
+url="http://love2d.org/"
+license=('zlib')
+depends=('luajit' 'physfs' 'freetype2' 'mpg123' 'openal' 'libvorbis' 'libmodplug' 'sdl2')
+source=("hg+https://bitbucket.org/rude/love#tag=0.10.2")
+makedepends=('mercurial')
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir"/love
+
+ # Update version information in configure script
+ msg "Updating version information"
+ head -c 15 platform/unix/configure.ac > configure.ac.tmp
+ echo " [0.10.2])" >> configure.ac.tmp
+ tail -n +2 platform/unix/configure.ac >> configure.ac.tmp
+ mv configure.ac.tmp platform/unix/configure.ac
+
+ # Skip installing desktop files, icons, etc
+ head -n 4 platform/unix/Makefile.am > Makefile.am.tmp
+ mv Makefile.am.tmp platform/unix/Makefile.am
+
+ # Generate a configure script for love-hg (note the suffix), then configure
+ msg "Generating makefiles"
+ sh platform/unix/automagic 10
+ ./configure --enable-silent-rules --prefix=/usr LDFLAGS=""
+
+ # Finally build
+ msg "Building"
+ make
+}
+
+package() {
+ cd "$srcdir"/love
+
+ make DESTDIR="$pkgdir" install
+
+ install -Dm0644 "license.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: