summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFirestar-Reimu2023-03-29 12:02:33 +0800
committerFirestar-Reimu2023-03-29 12:02:33 +0800
commit71f6b7949f16913383a8d705802c237a8d80ccc4 (patch)
tree855db8169bc92babd9637b5d616aca2fc90fa3a5
parentfcdde181f645ee125354a097948b48eeb33d7e4a (diff)
downloadaur-71f6b7949f16913383a8d705802c237a8d80ccc4.tar.gz
1.4.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7667b894a25b..bb423adc1ab6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lovelive-music-player-appimage
pkgdesc = A LoveLiver Music Player
- pkgver = 1.3.8
+ pkgver = 1.4.0
pkgrel = 1
url = https://github.com/LoveLiveMusicPlayer/LoveLiveMusicPlayer
arch = x86_64
@@ -8,11 +8,9 @@ pkgbase = lovelive-music-player-appimage
depends = zlib
depends = hicolor-icon-theme
depends = fuse2
- noextract = lovelive-music-player-appimage-1.3.8.AppImage
+ noextract = lovelive-music-player-appimage-1.4.0.AppImage
options = !strip
- source_x86_64 = lovelive-music-player-appimage-1.3.8.AppImage::https://github.com/LoveLiveMusicPlayer/LoveLiveMusicPlayer/releases/download/1.3.8/LLMP-1.3.8-x64-linux.AppImage
- source_x86_64 = https://raw.githubusercontent.com/LoveLiveMusicPlayer/LoveLiveMusicPlayer/1.3.8/LICENSE
- sha256sums_x86_64 = 40b55713b828597dd7a292a407970bdf7c3811b3149a57c0dc4af1477f50e134
- sha256sums_x86_64 = 5e98c15fe806a18f79422d2cd0c4587129f4e03081b5ab4c030627d6f6840d68
+ source_x86_64 = lovelive-music-player-appimage-1.4.0.AppImage::https://picbed-cdn.zhushenwudi.top/llmp-oss/LLMP/version/1.4.0/LoveLive%E9%9F%B3%E4%B9%90%E6%92%AD%E6%94%BE%E5%99%A8-1.4.0.AppImage
+ sha256sums_x86_64 = 805ab02d82b442cc7fe3e3baafc3f9d09422611410e022fa9933520e865722ca
pkgname = lovelive-music-player-appimage
diff --git a/PKGBUILD b/PKGBUILD
index bee330e059de..3495a67a3b8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=lovelive-music-player
pkgname="${_pkgname}"-appimage
-pkgver=1.3.8
+pkgver=1.4.0
pkgrel=1
pkgdesc="A LoveLiver Music Player"
arch=('x86_64')
@@ -13,12 +13,9 @@ license=('MIT')
depends=('zlib' 'hicolor-icon-theme' 'fuse2')
options=(!strip)
_appimage="${pkgname}-${pkgver}.AppImage"
-source_x86_64=("${_appimage}::https://github.com/LoveLiveMusicPlayer/LoveLiveMusicPlayer/releases/download/${pkgver}/LLMP-${pkgver}-x64-linux.AppImage"
- "https://raw.githubusercontent.com/LoveLiveMusicPlayer/LoveLiveMusicPlayer/${pkgver}/LICENSE"
- )
+source_x86_64=("${_appimage}::https://picbed-cdn.zhushenwudi.top/llmp-oss/LLMP/version/${pkgver}/LoveLive%E9%9F%B3%E4%B9%90%E6%92%AD%E6%94%BE%E5%99%A8-${pkgver}.AppImage")
noextract=("${_appimage}")
-sha256sums_x86_64=('40b55713b828597dd7a292a407970bdf7c3811b3149a57c0dc4af1477f50e134'
- '5e98c15fe806a18f79422d2cd0c4587129f4e03081b5ab4c030627d6f6840d68')
+sha256sums_x86_64=('805ab02d82b442cc7fe3e3baafc3f9d09422611410e022fa9933520e865722ca')
prepare() {
chmod +x "${_appimage}"
@@ -36,7 +33,6 @@ build() {
package() {
# AppImage
install -Dm755 "${srcdir}/${_appimage}" "${pkgdir}/opt/${pkgname}/${pkgname}.AppImage"
- install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/opt/${pkgname}/LICENSE"
# Desktop file
install -Dm644 "${srcdir}/squashfs-root/${_pkgname}.desktop"\
@@ -49,8 +45,4 @@ package() {
# Symlink executable
install -dm755 "${pkgdir}/usr/bin"
ln -s "/opt/${pkgname}/${pkgname}.AppImage" "${pkgdir}/usr/bin/${_pkgname}"
-
- # Symlink license
- install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
- ln -s "/opt/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}