summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Hu2015-06-30 13:16:32 +0100
committerNick Hu2015-06-30 13:16:32 +0100
commit6a40e5cf1e6fd00753527f267488bf50cb0d56c3 (patch)
treef8f23e14430250afb3a8fa310f13184e04be2aa6
downloadaur-6a40e5cf1e6fd00753527f267488bf50cb0d56c3.tar.gz
AUR4 migration
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30063796f8ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = low_battery_suspend
+ pkgdesc = Simple bash script to suspend the system based on the output of acpi.
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/NickHu/low_battery_suspend
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = bash
+ depends = acpi
+ source = https://github.com/NickHu/low_battery_suspend/archive/1.1.tar.gz
+ md5sums = ee046934ade58964ed215eafef33b49b
+
+pkgname = low_battery_suspend
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26e31ab5e46d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Nick Hu <me@nickhu.co.uk>
+
+pkgname=low_battery_suspend
+pkgver=1.1
+pkgrel=1
+pkgdesc="Simple bash script to suspend the system based on the output of acpi."
+arch=('i686' 'x86_64')
+url="https://github.com/NickHu/low_battery_suspend"
+license=('MIT')
+depends=('bash' 'acpi')
+source=("https://github.com/NickHu/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('ee046934ade58964ed215eafef33b49b')
+
+package()
+{
+ install -d ${pkgdir}/usr/bin
+ install -d ${pkgdir}/usr/lib/systemd/system
+ install -m 755 ${srcdir}/${pkgname}-${pkgver}/low_battery_suspend ${pkgdir}/usr/bin/low_battery_suspend
+ install -m 644 -t ${pkgdir}/usr/lib/systemd/system ${srcdir}/${pkgname}-${pkgver}/systemd/*
+}