summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorburt1iband2016-06-18 02:06:49 -0500
committerburt1iband2016-06-18 02:06:49 -0500
commite57ec982c66e20063a1fdc9c7634e753ec48a4cb (patch)
tree5060b4e0bff612119fbc31939d37499d8fe31a49
downloadaur-e57ec982c66e20063a1fdc9c7634e753ec48a4cb.tar.gz
lpclic: a better way to use linphonec
lpclic makes linphonec, the linphone CLI more usable by optimizing the display of the command history.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7de1af95dfcb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lpclic
+ pkgdesc = Optimizes the command history for the linphonec CLI for linphone
+ pkgver = 0.4.0.1
+ pkgrel = 1
+ url = https://github.com/burt1iband/lpclic
+ arch = any
+ license = GPL
+ depends = bash
+ depends = sed
+ depends = linphone
+ provides = lpclic
+ conflicts = lpclic
+ source = git+https://github.com/burt1iband/lpclic.git
+ md5sums = SKIP
+
+pkgname = lpclic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59c94ad19364
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+### Arch_Linux PKGBUILD for lpclic
+## Maintainer: B.H. <es_vinux@vinuxproject.org>
+pkgname=lpclic
+_pkgname=lpclic
+pkgver=0.4.0.1
+pkgrel=1
+pkgdesc="Optimizes the command history for the linphonec CLI for linphone"
+arch=('any')
+url="https://github.com/burt1iband/lpclic"
+license=('GPL')
+source=("git+${url}.git")
+depends=('bash' 'sed' 'linphone')
+provides=('lpclic')
+conflicts=('lpclic')
+md5sums=('SKIP')
+
+package() {
+cd "${srcdir}/${_pkgname}"
+ install -d "$pkgdir/usr/bin"
+ install -m 755 $_pkgname $pkgdir/usr/bin/
+ install -d "$pkgdir/etc/lpclic"
+ install -m 644 lpc_favorites "$pkgdir/etc/lpclic/"
+ install -m 644 lpc.conf ${pkgdir}/etc/lpclic/
+ install -d "$pkgdir/usr/share/doc/lpclic"
+ install -m 644 change.log ${pkgdir}/usr/share/doc/lpclic
+ install -m 644 lpc.conf ${pkgdir}/usr/share/doc/lpclic
+ install -m 644 lpc_favorites ${pkgdir}/usr/share/doc/lpclic
+ install -m 644 README ${pkgdir}/usr/share/doc/lpclic
+ install -d "$pkgdir/usr/share/man/man1"
+ install -m 644 lpclic.1.gz $pkgdir/usr/share/man/man1/
+}