summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2023-08-08 01:28:39 +0800
committertaotieren2023-08-08 01:28:39 +0800
commitb05c482adb94ee25ef1d498f6ecd71a515090511 (patch)
tree18f2be92e3097c9e27696e79c38aaee4f2407bd3
parented76e68ce4a6548b5f82a86160cf690f0eef775e (diff)
downloadaur-lpcscrypt-bin.tar.gz
Update 2.1.2-2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97c89efe5cb5..f7fc3a23cd08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lpcscrypt-bin
pkgdesc = LPCScrypt is the recommended tool for programming the latest versions of CMSIS-DAP and J-Link firmware onto boards with Link2/LPC-Link2 debug probes.
pkgver = 2.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.nxp.com/design/microcontrollers-developer-resources/lpcscrypt-v2-1-2:LPCSCRYPT
arch = x86_64
license = Commercial
diff --git a/PKGBUILD b/PKGBUILD
index 3968460aa0ed..d238ebb5160c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname="lpcscrypt-bin"
pkgver=2.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="LPCScrypt is the recommended tool for programming the latest versions of CMSIS-DAP and J-Link firmware onto boards with Link2/LPC-Link2 debug probes."
arch=("x86_64")
makedepends=('imagemagick')
@@ -45,15 +45,18 @@ package() {
msg2 'Installing LPCScrypt'
tar xf "build/data.tar.gz" -C "${pkgdir}/"
mv "${pkgdir}/lib" "${pkgdir}/usr"
+ mv -v "${pkgdir}/usr/local/" -T "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/share/lpcscrypt-2.1.2_57" "${pkgdir}/usr/share/lpcscrypt"
+ find "$pkgdir"/usr -type f -exec chmod 644 "{}" \;
+ find "$pkgdir"/usr -type d -exec chmod 755 "{}" \;
msg2 'Instalation of binary file'
install -Dm0755 /dev/stdin "${pkgdir}/usr/bin/${pkgname%-bin}" <<END
#!/bin/sh
-/usr/local/lpcscrypt-2.1.2_57/bin/lpcscrypt "\$@"
+/usr/share/lpcscrypt/bin/lpcscrypt "\$@"
END
-
- msg2 'Instalation of license file'
- install -dm0755 "${pkgdir}/usr/share/licenses/${pkgname%-bin}/"
- cp -rv "${pkgdir}/usr/local/lpcscrypt-2.1.2_57/eula" "${pkgdir}/usr/share/licenses/${pkgname%-bin}/"
+ find "$pkgdir"/usr/share/lpcscrypt/bin -type f -exec chmod 755 "{}" \;
+ rm -f "$pkgdir"/usr/share/lpcscrypt/scripts/99-lpcscrypt.rules
+ find "$pkgdir"/usr/share/lpcscrypt/scripts -type f -exec chmod 755 "{}" \;
}
#