summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Seidel2016-01-31 21:14:52 +0100
committerStefan Seidel2016-01-31 21:14:52 +0100
commit627af7ed6d2bbdc797150e9e1d0381762882c9b7 (patch)
treecf1afc5eee5c847dc1b043f3c5e93b73a2dc0000
parent537417c7af3d5d30d08329dfea6d5677ea53d266 (diff)
downloadaur-627af7ed6d2bbdc797150e9e1d0381762882c9b7.tar.gz
correct python dependency and make more things use qt3 explicitly
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--build-qt3.patch94
-rw-r--r--lcms-118.patch25
4 files changed, 107 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a61e244ab75..c911e6b9785c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,24 @@
# Generated by mksrcinfo v8
-# Mon Dec 21 12:29:19 UTC 2015
+# Sun Jan 31 20:13:14 UTC 2016
pkgbase = lprof
pkgdesc = Imaging device calibration tool
pkgver = 1.11.4.1
- pkgrel = 4
+ pkgrel = 5
url = http://lprof.sourceforge.net/
arch = i686
arch = x86_64
license = GPL
- makedepends = python>=1.53
+ makedepends = python2
makedepends = scons
depends = qt3
depends = lcms>=1.12
depends = vigra>=1.3
source = http://downloads.sourceforge.net/lprof/lprof-1.11.4.1.tar.gz
source = lcms-118.patch
+ source = build-qt3.patch
sha256sums = 366b9e9ea720d36d5dbe71af6971647bc37307a083e61e4aa8dbfb521d111d61
- sha256sums = 2be7ed993b75b9ac42dd0643e9408601617a2718cb3f9e10f956d26a955c2c07
+ sha256sums = bbeb725a2f4da204424d752f1814a9ffd20477de66d9ae9b2da3b02c2f61a8a4
+ sha256sums = 27049e58b8308ee6c0f23f4e94baea8a8b45db9ce61b4e9136130e21ddcd08b0
pkgname = lprof
diff --git a/PKGBUILD b/PKGBUILD
index 3381b4b5abb9..c2b7d6aed7e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,25 @@
# Contributor: Branko Vukelic (bg.branko@gmail.com)
pkgname=lprof
pkgver=1.11.4.1
-pkgrel=4
+pkgrel=5
arch=(i686 x86_64)
pkgdesc="Imaging device calibration tool"
url="http://lprof.sourceforge.net/"
license="GPL"
depends=('qt3' 'lcms>=1.12' 'vigra>=1.3')
-makedepends=('python>=1.53' 'scons')
+makedepends=('python2' 'scons')
source=(http://downloads.sourceforge.net/lprof/${pkgname}-${pkgver}.tar.gz
- lcms-118.patch)
+ lcms-118.patch
+ build-qt3.patch)
sha256sums=('366b9e9ea720d36d5dbe71af6971647bc37307a083e61e4aa8dbfb521d111d61'
- '2be7ed993b75b9ac42dd0643e9408601617a2718cb3f9e10f956d26a955c2c07')
+ 'bbeb725a2f4da204424d752f1814a9ffd20477de66d9ae9b2da3b02c2f61a8a4'
+ '27049e58b8308ee6c0f23f4e94baea8a8b45db9ce61b4e9136130e21ddcd08b0')
prepare() {
cd ${pkgname}-${pkgver}
patch -p0<../lcms-118.patch
+ patch -p0<../build-qt3.patch
sed -i "s/'tiff'/'tiff','png'/" SConstruct || return 1
rm -rf scons*
}
diff --git a/build-qt3.patch b/build-qt3.patch
new file mode 100644
index 000000000000..165426c0e537
--- /dev/null
+++ b/build-qt3.patch
@@ -0,0 +1,94 @@
+--- SConstruct
++++ SConstruct
+@@ -81,8 +81,8 @@ def DoWithVariables(variables, prefix, what):
+
+ def CheckForQtAt(context, qtdir):
+ context.Message('Checking for Qt at %s... ' % qtdir)
+- libp = os.path.join(qtdir, 'lib')
+- cppp = os.path.join(qtdir, 'include')
++ libp = os.path.join(qtdir, 'lib', 'qt3')
++ cppp = os.path.join(qtdir, 'include', 'qt3')
+ result = AttemptLinkWithVariables(context,
+ { "LIBS": "qt-mt", "LIBPATH": libp , "CPPPATH": cppp },
+ """
+@@ -113,7 +113,7 @@
+ potential_qt_dirs.insert(0, os.environ[ 'QTDIR' ])
+
+ if env[ 'qt_directory' ] != "/":
+- uic_path = os.path.join(env['qt_directory'], 'bin', 'uic')
++ uic_path = os.path.join(env['qt_directory'], 'bin', 'uic-qt3')
+ if os.path.isfile(uic_path):
+ potential_qt_dirs.insert(0, env[ 'qt_directory' ])
+ else:
+@@ -124,16 +124,16 @@
+ context.env.Replace(QTDIR = i)
+ if CheckForQtAt(context, i):
+ # additional checks to validate QT installation
+- if not os.path.isfile(os.path.join(i, 'bin', 'uic')):
++ if not os.path.isfile(os.path.join(i, 'bin', 'uic-qt3')):
+ print "QT - failed to find uic."
+ return 0
+- if not os.path.isfile(os.path.join(i, 'bin', 'moc')):
++ if not os.path.isfile(os.path.join(i, 'bin', 'moc-qt3')):
+ print "QT - failed to find moc."
+ return 0
+- if not os.path.exists(os.path.join(i, 'lib')):
++ if not os.path.exists(os.path.join(i, 'lib', 'qt3')):
+ print "QT - failed to find QT lib path."
+ return 0
+- if not os.path.exists(os.path.join(i, 'include')):
++ if not os.path.exists(os.path.join(i, 'include', 'qt3')):
+ print "QT - failed to find QT include path."
+ return 0
+ return 1
+@@ -210,9 +210,9 @@ env['QT_AUTOSCAN'] = 1
+ print "QTDIR = " + env['QTDIR']
+ env.Replace(QT_BINPATH = os.path.join ( env['QTDIR'] , 'bin'))
+ print 'Setting up QT_BINPATH = ' + env['QT_BINPATH']
+-env.Replace(QT_UIC = os.path.join ( env['QTDIR'] , 'bin', 'uic'))
++env.Replace(QT_UIC = os.path.join ( env['QTDIR'] , 'bin', 'uic-qt3'))
+ print 'Setting up QT_UIC = ' + env['QT_UIC']
+-env.Replace(QT_MOC = os.path.join ( env['QTDIR'] , 'bin', 'moc'))
++env.Replace(QT_MOC = os.path.join ( env['QTDIR'] , 'bin', 'moc-qt3'))
+ print 'Setting up QT_MOC = ' + env['QT_MOC']
+ # env.Append(QT_DEBUG = 1)
+
+--- createtrans.sh
++++ createtrans.sh
+@@ -2,7 +2,7 @@
+
+ echo -n "Generating project file for translations..."
+
+-qmake -project -o translations.pro
++qmake-qt3 -project -o translations.pro
+ echo "done"
+ echo >> translations.pro
+ echo -n "TRANSLATIONS += " >> translations.pro
+@@ -13,7 +13,7 @@
+
+ echo -n "Updating translations..."
+ mkdir -p translations
+-lupdate translations.pro
++lupdate-qt3 translations.pro
+ echo "done"
+ echo "ts and po files output in translations/ "
+
+--- comptrans.sh
++++ comptrans.sh
+@@ -1,6 +1,6 @@
+ echo -n "Generating project file for translations..."
+
+-qmake -project -o translations.pro
++qmake-qt3 -project -o translations.pro
+ echo "done"
+ echo >> translations.pro
+ echo -n "TRANSLATIONS += " >> translations.pro
+@@ -10,7 +10,7 @@
+ # requires to actually load its translations.
+
+ echo -n "Compiling po and ts files..."
+-lrelease translations.pro
++lrelease-qt3 translations.pro
+ mkdir data/translations
+ cp translations/*.qm data/translations/
+ rm -f translations/*.qm
diff --git a/lcms-118.patch b/lcms-118.patch
index 0041a76b9b63..55afdfbb8dd2 100644
--- a/lcms-118.patch
+++ b/lcms-118.patch
@@ -10,28 +10,3 @@
/* Misc operations ------------------------------------------------------------------------ */
---- SConstruct
-+++ SConstruct
-@@ -81,8 +81,8 @@ def DoWithVariables(variables, prefix, what):
-
- def CheckForQtAt(context, qtdir):
- context.Message('Checking for Qt at %s... ' % qtdir)
-- libp = os.path.join(qtdir, 'lib')
-- cppp = os.path.join(qtdir, 'include')
-+ libp = os.path.join(qtdir, 'lib', 'qt3')
-+ cppp = os.path.join(qtdir, 'include', 'qt3')
- result = AttemptLinkWithVariables(context,
- { "LIBS": "qt-mt", "LIBPATH": libp , "CPPPATH": cppp },
- """
-@@ -210,9 +210,9 @@ env['QT_AUTOSCAN'] = 1
- print "QTDIR = " + env['QTDIR']
- env.Replace(QT_BINPATH = os.path.join ( env['QTDIR'] , 'bin'))
- print 'Setting up QT_BINPATH = ' + env['QT_BINPATH']
--env.Replace(QT_UIC = os.path.join ( env['QTDIR'] , 'bin', 'uic'))
-+env.Replace(QT_UIC = os.path.join ( env['QTDIR'] , 'bin', 'uic-qt3'))
- print 'Setting up QT_UIC = ' + env['QT_UIC']
--env.Replace(QT_MOC = os.path.join ( env['QTDIR'] , 'bin', 'moc'))
-+env.Replace(QT_MOC = os.path.join ( env['QTDIR'] , 'bin', 'moc-qt3'))
- print 'Setting up QT_MOC = ' + env['QT_MOC']
- # env.Append(QT_DEBUG = 1)
-