summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAuric Vente2022-07-02 07:11:51 -0600
committerAuric Vente2022-07-02 07:11:51 -0600
commitc22fd86fc5448a7b9ac6657f6c886938edbfabaa (patch)
tree9d834745f3de0a0b9309c255a991d926265318f7
downloadaur-c22fd86fc5448a7b9ac6657f6c886938edbfabaa.tar.gz
first
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0eaa0443042f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lq-git
+ pkgdesc = File listing tool. Written in Nim.
+ pkgver = r281.1e25717
+ pkgrel = 1
+ url = https://github.com/madprops/lq
+ arch = x86_64
+ license = GPL2
+ makedepends = nim
+ makedepends = nimble
+ source = lq-git::git+https://github.com/madprops/lq.git
+ sha256sums = SKIP
+
+pkgname = lq-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2bddd7a0f667
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: madprops <mprops at protonmail dot com>
+
+pkgname="lq-git"
+pkgdesc="File listing tool. Written in Nim."
+pkgver=r281.1e25717
+pkgrel=1
+arch=("x86_64")
+url="https://github.com/madprops/lq"
+license=("GPL2")
+makedepends=("nim" "nimble")
+sha256sums=("SKIP")
+source=("$pkgname::git+https://github.com/madprops/lq.git")
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd lq-git
+ nimble install -d -y
+ nim compile -d:release -o=bin/lq-release-linux "src/lq.nim"
+}
+
+package() {
+ cd lq-git
+ install -D -m755 bin/lq-release-linux "$pkgdir/usr/bin/lq"
+} \ No newline at end of file