aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpfych2024-03-18 17:54:22 +1100
committerpfych2024-03-18 17:54:22 +1100
commit53205be2d9e151a884c04db12bee5952e3ead1c1 (patch)
tree617ed275f0f6e6b7810d217dd1c2b854b9d6a4a8
parentd30f582a3eb9dd7c17ed1267c7d8c51c01b40b9c (diff)
downloadaur-53205be2d9e151a884c04db12bee5952e3ead1c1.tar.gz
Fix issue with desktop entry & update script to run on Wayland
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--beatoraja.sh2
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c684b8bad03b..cd65e1d2a161 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lr2oraja
pkgdesc = The latest build of beatoraja, but compiled using LR2 judges and gauges.
pkgver = build6711481041
- pkgrel = 2
+ pkgrel = 3
arch = x86_64
license = GPL3
license = GPL3
@@ -20,7 +20,7 @@ pkgbase = lr2oraja
sha256sums = ef23b516537b4f52c306fd61ab9c4197192c06b7202b3b27b63481fec1042a26
sha256sums = 3754959d5d6f121dbeed3a78dec2b91a26e915ff4ce68fdee4262b89ad150cb9
sha256sums = a65d1290d3ee7710f9327c040e6369bf7587eb3609835ed782caaf0ac02d84ed
- sha256sums = a1c1d6ee606d042934ec1ee503a9300d5b225f3c4031be144a3c5bca24f0d042
+ sha256sums = fd2638ec66871deec093f736298b5592caadb89b5686648a28e4d082c207bb50
sha256sums = 0ec1382690cd847055d1b8e6da36ad6846598b45b25acca5eb5e301a5048da03
pkgname = lr2oraja
diff --git a/PKGBUILD b/PKGBUILD
index 8a546ab95bee..02340ad2dbdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pfych <contact at pfy dot ch>
pkgname=lr2oraja
pkgver=build6711481041
-pkgrel=2
+pkgrel=3
pkgdesc="The latest build of beatoraja, but compiled using LR2 judges and gauges."
arch=('x86_64')
depends=('liberica-jre-8-full-bin' 'portaudio')
@@ -19,7 +19,7 @@ sha256sums=(
'ef23b516537b4f52c306fd61ab9c4197192c06b7202b3b27b63481fec1042a26' # skin.zip
'3754959d5d6f121dbeed3a78dec2b91a26e915ff4ce68fdee4262b89ad150cb9' # bokutachiIR
'a65d1290d3ee7710f9327c040e6369bf7587eb3609835ed782caaf0ac02d84ed' # libjportaudio.so
- 'a1c1d6ee606d042934ec1ee503a9300d5b225f3c4031be144a3c5bca24f0d042' # beatoraja.sh
+ 'fd2638ec66871deec093f736298b5592caadb89b5686648a28e4d082c207bb50' # beatoraja.sh
'0ec1382690cd847055d1b8e6da36ad6846598b45b25acca5eb5e301a5048da03' # lr2oraja-icon.png
)
license=(
@@ -64,7 +64,7 @@ package() {
echo "Exec=/usr/bin/beatoraja" >> "$desktopEntry"
echo "Version=$pkgver" >> "$desktopEntry"
echo "Name=LR2oraja" >> "$desktopEntry"
- echo "Categories=Games;" >> "$desktopEntry"
+ echo "Categories=Game;" >> "$desktopEntry"
echo "Icon=lr2oraja-icon" >> "$desktopEntry"
if [ -z "$XDG_CONFIG_HOME" ]; then
diff --git a/beatoraja.sh b/beatoraja.sh
index dfc04b6b4f2a..d558b0616b80 100644
--- a/beatoraja.sh
+++ b/beatoraja.sh
@@ -3,4 +3,4 @@ export _JAVA_OPTIONS='-Dsun.java2d.opengl=true -Dawt.useSystemAAFontSettings=on
export LD_LIBRARY_PATH='/usr/lib/'
export LD_PRELOAD='/usr/lib/libjportaudio.so'
cd "/opt/beatoraja"
-SHUT_UP_TACHI=yes java -Xms1g -Xmx4g -cp beatoraja.jar:ir/* bms.player.beatoraja.MainLoader
+SHUT_UP_TACHI=yes java -Djdk.gtk.version=2 -Xms1g -Xmx4g -cp beatoraja.jar:ir/* bms.player.beatoraja.MainLoader