summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:37:22 +0200
committerStefan Husmann2015-06-09 00:37:22 +0200
commit034a5004afa8ab07eaacf27e21eb97e7a042baaf (patch)
tree1d4e02ea0da78081ac93683f1efc31f0145c9ef6
downloadaur-034a5004afa8ab07eaacf27e21eb97e7a042baaf.tar.gz
initial version
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE27
-rw-r--r--PKGBUILD26
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b362da7bd83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = lrexlib
+ pkgdesc = regular expression libraries for lua
+ pkgver = 2.7.2
+ pkgrel = 1
+ url = http://rrthomas.github.com/lrexlib/
+ arch = i686
+ arch = x86_64
+ license = custom:lua
+ makedepends = git2cl-git
+ makedepends = luarocks
+ depends = lua
+ depends = oniguruma
+ depends = tre
+ depends = pcre
+ conflicts = lrexlib-pcre5.1
+ conflicts = lrexlib-pcre
+ source = LICENSE
+ md5sums = 57bcf624164eaa14fd37807983ea219b
+
+pkgname = lrexlib
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..6cbc66488be6
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,27 @@
+License of Lrexlib release
+--------------------------
+
+Copyright (C) Reuben Thomas 2000-2012
+Copyright (C) Shmuel Zeigerman 2004-2012
+
+Permission is hereby granted, free of charge, to any person
+obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute,
+sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so,
+subject to the following conditions:
+
+The above copyright notice and this permission notice shall
+be included in all copies or substantial portions of the
+Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY
+KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
+WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
+PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS
+OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
+OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8437be761dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: strata <strata@dropswitch.net>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=lrexlib
+pkgver=2.7.2
+pkgrel=1
+pkgdesc="regular expression libraries for lua"
+arch=('i686' 'x86_64')
+url="http://rrthomas.github.com/lrexlib/"
+source=('LICENSE')
+md5sums=('57bcf624164eaa14fd37807983ea219b')
+license=('custom:lua')
+depends=('lua' 'oniguruma' 'tre' 'pcre')
+makedepends=('git2cl-git' 'luarocks')
+conflicts=('lrexlib-pcre5.1' 'lrexlib-pcre')
+
+package() {
+ luarocks --tree=${pkgdir}/usr install $pkgname-gnu
+ luarocks --tree=${pkgdir}/usr install $pkgname-oniguruma
+ luarocks --tree=${pkgdir}/usr install $pkgname-pcre
+ luarocks --tree=${pkgdir}/usr install $pkgname-posix
+ luarocks --tree=${pkgdir}/usr install $pkgname-tre
+ install -Dm644 LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+