summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordotiful2020-04-18 21:57:42 +0300
committerdotiful2020-04-18 21:57:42 +0300
commit4bc509a7685cf267a4ea1847950414c4405d973f (patch)
treef1560e5b04a052e916781d43724286545886e1ac
downloadaur-4bc509a7685cf267a4ea1847950414c4405d973f.tar.gz
0.7.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82077ba99b65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lscolors
+ pkgdesc = A Rust library to colorize paths using LS_COLORS
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/sharkdp/lscolors
+ arch = x86_64
+ license = MIT
+ provides = lscolors
+ source = https://github.com/sharkdp/lscolors/releases/download/v0.7.0/lscolors-v0.7.0-x86_64-unknown-linux-musl.tar.gz
+ sha256sums = 7c6fddef3d58868eda5c33d7f00239099e16e267475c5334e395c68285b941f1
+
+pkgname = lscolors
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7285ce0715ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Art Dev <artdevjs at gmail dot com>
+
+pkgname="lscolors"
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="A Rust library to colorize paths using LS_COLORS"
+arch=("x86_64")
+url="https://github.com/sharkdp/lscolors"
+license=("MIT")
+depends=()
+optdepends=()
+makedepends=()
+checkdepends=()
+provides=("lscolors")
+source=("https://github.com/sharkdp/lscolors/releases/download/v${pkgver}/${pkgname}-v${pkgver}-${CARCH}-unknown-linux-musl.tar.gz")
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname}-v${pkgver}-${CARCH}-unknown-linux-musl/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-v${pkgver}-${CARCH}-unknown-linux-musl/LICENSE-MIT" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+sha256sums=('7c6fddef3d58868eda5c33d7f00239099e16e267475c5334e395c68285b941f1')