summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordotiful2020-05-01 01:05:27 +0300
committerdotiful2020-05-01 01:05:27 +0300
commit4826e73b20b53649fcf238e31d56cbba300c7565 (patch)
tree9f44e7e6239b2c7c2d2a4f075d99b799ff1bf129
downloadaur-4826e73b20b53649fcf238e31d56cbba300c7565.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..202e4e781e17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lsd-bin
+ pkgdesc = The next gen ls command
+ pkgver = 0.17.0
+ pkgrel = 1
+ url = https://github.com/Peltoche/lsd
+ arch = x86_64
+ license = Apache
+ provides = barrier
+ conflicts = lsd
+ conflicts = lsd-git
+ noextract = lsd-0.17.0-x86_64.tar.xz
+ options = !emptydirs
+ options = !makeflags
+ options = !strip
+ source = https://github.com/Peltoche/lsd/releases/download/0.17.0/lsd-0.17.0-x86_64-unknown-linux-musl.tar.gz
+ sha256sums = 823da6a8ce16d95edc04514608e0da0ec54330d148228b77c2daa5db6a3d98bf
+
+pkgname = lsd-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99e70e8dbb24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Art Dev <artdevjs at gmail dot com>
+pkgname=lsd-bin
+_pkgname="lsd"
+pkgver=0.17.0
+pkgrel=1
+pkgdesc="The next gen ls command"
+arch=("x86_64")
+url="https://github.com/Peltoche/lsd"
+license=("Apache")
+provides=("lsd")
+conflicts=("lsd" "lsd-git")
+source=(
+ "lsd.tar.gz::https://github.com/Peltoche/lsd/releases/download/${pkgver}/${_pkgname}-${pkgver}-${CARCH}-unknown-linux-musl.tar.gz"
+)
+
+package(){
+ install -Dm755 ${srcdir}/${_pkgname}-${pkgver}-${CARCH}-unknown-linux-musl/${_pkgname} "${pkgdir}/usr/bin/${_pkgname}"
+
+ install -Dm644 ${srcdir}/${_pkgname}-${pkgver}-${CARCH}-unknown-linux-musl/autocomplete/${_pkgname}.bash-completion "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
+ install -Dm644 ${srcdir}/${_pkgname}-${pkgver}-${CARCH}-unknown-linux-musl/autocomplete/_${_pkgname} "${pkgdir}/usr/share/zsh/site-functions/_${_pkgname}"
+}
+
+sha256sums=('823da6a8ce16d95edc04514608e0da0ec54330d148228b77c2daa5db6a3d98bf')