summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Pascal2019-08-22 01:35:48 -0500
committerJeff Wright2020-01-31 08:15:25 -0800
commit0a39f6c73734c11772f57b0acb111b7be56ebbb2 (patch)
treebb2b9f5bb3cdf5542a717f2d344d4ee2c40bce2e
parent5cc4d2002515043a3cf3256a4ad56cb06bf3097f (diff)
downloadaur-0a39f6c73734c11772f57b0acb111b7be56ebbb2.tar.gz
Fix package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD37
2 files changed, 36 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93d74b4759e1..513d804d28d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,21 @@
pkgbase = lsd-git
- pkgdesc = A ls command with a lot of pretty colors.
- pkgver = 0.2.0
+ pkgdesc = The next gen ls command
+ pkgver = 0.16.0.381.gaa40bd2
pkgrel = 1
url = https://github.com/Peltoche/lsd
arch = i686
arch = x86_64
arch = armv6h
arch = armv7h
- license = Apache-2.0
+ license = Apache
makedepends = rust
makedepends = cargo
- depends = nerd-fonts-complete
+ makedepends = git
+ depends = gcc-libs
+ provides = lsd
+ conflicts = lsd
+ source = lsd::git+https://github.com/Peltoche/lsd.git
+ sha384sums = SKIP
pkgname = lsd-git
diff --git a/PKGBUILD b/PKGBUILD
index ac9a0e043eeb..29f7875255e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,36 @@
# Maintainer: Peltoche <dev@halium.fr>
-pkgname=lsd-git
-pkgver=0.2.0
+# Co-maintainer: Andrea Pascal <andrea@anodium.net>
+
+pkgname="lsd-git"
+_pkgname="lsd"
+pkgver=0.16.0.381.gaa40bd2
pkgrel=1
-depends=('nerd-fonts-complete')
-makedepends=('rust' 'cargo')
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-pkgdesc="A ls command with a lot of pretty colors."
+pkgdesc="The next gen ls command"
+arch=("i686" "x86_64" "armv6h" "armv7h")
url="https://github.com/Peltoche/lsd"
-license=('Apache-2.0')
+license=("Apache")
+depends=("gcc-libs")
+makedepends=("rust" "cargo" "git")
+provides=("lsd")
+conflicts=("lsd")
+source=("$_pkgname::git+https://github.com/Peltoche/lsd.git")
+sha384sums=("SKIP")
+
+pkgver() {
+ cd $_pkgname
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2|cut -d\- -f1).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
build() {
- return 0
+ cd $_pkgname
+ cargo build --release --locked
+}
+
+check() {
+ cd $_pkgname
+ cargo test --release --locked
}
package() {
- cd $srcdir
- cargo install --root="$pkgdir" --git=https://github.com/Peltoche/lsd
+ install -D -m755 $srcdir/$_pkgname/target/release/lsd $pkgdir/usr/bin/lsd
}