summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeltoche2018-11-25 14:07:24 +0100
committerPeltoche2018-11-25 14:08:17 +0100
commita3a703c9869ef549838e73ab57d4f2cb2faa7295 (patch)
tree7888b210ba9806a22e8a20f9311ea0452ab8cc2f
downloadaur-a3a703c9869ef549838e73ab57d4f2cb2faa7295.tar.gz
0.1.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e1ad5109073
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lsd-git
+ pkgdesc = A ls command with a lot of pretty colors.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/Peltoche/lsd
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = Apache-2.0
+ makedepends = rust
+ makedepends = cargo
+
+pkgname = lsd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32d1b0001f5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Peltoche <dev@halium.fr>
+pkgname=lsd-git
+pkgver=0.1.0
+pkgrel=1
+makedepends=('rust' 'cargo')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="A ls command with a lot of pretty colors."
+url="https://github.com/Peltoche/lsd"
+license=('Apache-2.0')
+
+build() {
+ return 0
+}
+
+package() {
+ cd $srcdir
+ cargo install --root="$pkgdir" --git=https://github.com/Peltoche/lsd
+}