summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2020-08-01 20:39:26 +0200
committerMagnus Boman2020-08-01 20:39:26 +0200
commitaa15779259bd625697c1a31a90c62eb4e7dae7df (patch)
tree4e1b14805a849037b683b2d635638b4596ffb24d
parent864a729dc2c08335f53ba6820b8dd217eee4995e (diff)
downloadaur-aa15779259bd625697c1a31a90c62eb4e7dae7df.tar.gz
lshw-git: fix sed
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 503f18cd5b12..02463db4d465 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lshw-git
- pkgdesc = A small tool to provide detailed information on the hardware configuration of the machine.
+ pkgdesc = A small tool to provide detailed information on the hardware configuration of the machine
pkgver = B.02.19.r39.g9ae06b4
- pkgrel = 1
+ pkgrel = 2
url = https://ezix.org/project/wiki/HardwareLiSter
arch = x86_64
license = GPL
@@ -10,7 +10,7 @@ pkgbase = lshw-git
makedepends = git
depends = gcc-libs
depends = hwids
- optdepends = gtk3
+ optdepends = gtk3: for gtk-lshw
provides = lshw
conflicts = lshw
source = git+https://ezix.org/src/pkg/lshw.git
diff --git a/PKGBUILD b/PKGBUILD
index e76129de070e..d0457de3af54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
pkgname=lshw-git
pkgver=B.02.19.r39.g9ae06b4
-pkgrel=1
-pkgdesc='A small tool to provide detailed information on the hardware configuration of the machine.'
+pkgrel=2
+pkgdesc='A small tool to provide detailed information on the hardware configuration of the machine'
url=https://ezix.org/project/wiki/HardwareLiSter
license=(GPL)
arch=(x86_64)
depends=(gcc-libs hwids)
-optdepends=(gtk3)
+optdepends=('gtk3: for gtk-lshw')
makedepends=(gtk3 sqlite git)
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
@@ -25,7 +25,7 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
- sed -i 's|/usr/bin/gtk-lshw|/usr/sbin/gtk-lshw|' src/gui/integration/gtk-lshw.desktop
+ sed -i 's|/usr/sbin/gtk-lshw|/usr/bin/gtk-lshw|' src/gui/integration/gtk-lshw.desktop
}
build() {