summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-03-02 21:43:46 +0100
committersL1pKn072022-03-02 21:43:46 +0100
commit8c8a41d8f8600386ceea2226836c22327ffcf36c (patch)
tree29ad458331fe1c6de5d0e26568381d0d58b2340e
parentc84655a5d5cdcc41d60582e3be9250ba3f52e610 (diff)
downloadaur-8c8a41d8f8600386ceea2226836c22327ffcf36c.tar.gz
meh
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0ab6d75c403..81434b94ab0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,7 +38,7 @@ options=('!strip')
_create_links() {
# create soname links
- find "$pkgdir" -type f -name '*.so*' -print0 | while read -d $'\0' _lib; do
+ find "${pkgdir}" -type f -name '*.so*' -print0 | while read -d $'\0' _lib; do
_soname=$(dirname "${_lib}")/$(readelf -d "${_lib}" | grep -Po 'SONAME.*: \[\K[^]]*' || true)
_base=$(echo ${_soname} | sed -r 's/(.*)\.so.*/\1.so/')
[[ -e "${_soname}" ]] || ln -s $(basename "${_lib}") "${_soname}"