summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-02-27 00:42:20 +0100
committersL1pKn072022-02-27 00:42:52 +0100
commit74d99742ebbf5b48a16ead526de7bf77e78fba87 (patch)
treef6c4fb47c7860155dc7d046ec4d63d1b43a0f680
parent65f57e69b393667da3031e6be08c12edd7e37ab9 (diff)
downloadaur-74d99742ebbf5b48a16ead526de7bf77e78fba87.tar.gz
Add custom Makefile for build minimal libraries. (this is much faster than before)
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--Makefile.minimal32
-rw-r--r--PKGBUILD22
4 files changed, 57 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2a3adbe383a..6ed340855903 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lsi-openpegasus
pkgdesc = Openpegasus libs for LSI (Broadcom) Raid products
pkgver = 2.14.1
- pkgrel = 4
+ pkgrel = 5
url = http://www.avagotech.com/products/server-storage
arch = x86_64
license = custom:TOG
@@ -9,11 +9,12 @@ pkgbase = lsi-openpegasus
makedepends = openssl
makedepends = net-snmp
makedepends = openslp
- makedepends = libxcrypt
makedepends = setconf
depends = sqlite
depends = openssl
+ depends = libxcrypt
depends = libcrypt.so
+ options = debug
source = https://collaboration.opengroup.org/pegasus/documents/32572/pegasus-2.14.1.tar.gz
source = https://src.fedoraproject.org/rpms/tog-pegasus/raw/main/f/pegasus-2.7.0-PIE.patch
source = https://src.fedoraproject.org/rpms/tog-pegasus/raw/main/f/pegasus-2.9.0-no-rpath.patch
@@ -21,6 +22,8 @@ pkgbase = lsi-openpegasus
source = https://src.fedoraproject.org/rpms/tog-pegasus/raw/main/f/pegasus-2.14.1-build-fixes.patch
source = https://src.fedoraproject.org/rpms/tog-pegasus/raw/main/f/pegasus-2.14.1-ssl-include.patch
source = https://src.fedoraproject.org/rpms/tog-pegasus/raw/main/f/pegasus-2.14.1-openssl-1.1-fix.patch
+ source = https://src.fedoraproject.org/rpms/tog-pegasus/raw/main/f/pegasus-2.14.1-build-fixes-2.patch
+ source = Makefile.minimal
sha256sums = 9f2f13a35da218f3cb6e8478246ff7c4d3010560bb4d5de9cbf4272d48e353fb
sha256sums = e3924bdb81a4dd2cedfb9c7ba669cb01b32f4c4e16b3af4c06f9a2426a9274d1
sha256sums = 66141323d6de100d9a1805f614a950944e223a36026b62b1a823c8aa148f26df
@@ -28,5 +31,7 @@ pkgbase = lsi-openpegasus
sha256sums = 5863314f2ff17c32bc340efd5241f809bc1372b8e2fde0b3a2e22c7ab9b64281
sha256sums = 5de02253442ef8cb3b6f744fa4dd3237b66d96911ab8badd63336a7e1d28a429
sha256sums = deb3e52e5406419cc42d15f1a668ed291ef8337217bb5bc9cefd01ef3b804371
+ sha256sums = 832be374999213a6d940e84c449a7c3566d9dda2b1c2348d7bc601bc907fc228
+ sha256sums = 7cd222778cc829536ef6fb9c6fb688ac1114f6492cfa61b3881e655c5f38ac96
pkgname = lsi-openpegasus
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..43b0a820ce2f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!.SRCINFO
!PKGBUILD
+!Makefile.minimal
diff --git a/Makefile.minimal b/Makefile.minimal
new file mode 100644
index 000000000000..32295c02162c
--- /dev/null
+++ b/Makefile.minimal
@@ -0,0 +1,32 @@
+ROOT = .
+
+include $(ROOT)/env_var.status
+include $(ROOT)/mak/config.mak
+
+DIRS = src
+
+TEST_DIRS =
+
+include $(ROOT)/mak/recurse.mak
+
+.PHONY: FORCE
+
+FORCE:
+
+minimal: FORCE
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/Common -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/General -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/slp/slp_client -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/Client -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/Config -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/Query/QueryCommon -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/CQL -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/WQL -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/Query/QueryExpression -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/Provider -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/Repository -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/ExportServer -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/Listener -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/Server/ProviderRegistrationManager -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/Handler -f Makefile
+ $(MAKE) --directory=$(PEGASUS_ROOT)/src/Pegasus/IndicationService -f Makefile
diff --git a/PKGBUILD b/PKGBUILD
index 38da156ccefe..a9e3846fca6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
pkgname=lsi-openpegasus
pkgver=2.14.1
-pkgrel=4
+pkgrel=5
pkgdesc="Openpegasus libs for LSI (Broadcom) Raid products"
arch=('x86_64')
url='http://www.avagotech.com/products/server-storage'
license=('custom:TOG')
depends=('sqlite'
'openssl'
+ 'libxcrypt'
'libcrypt.so'
)
makedepends=('icu'
'openssl'
'net-snmp'
'openslp'
- 'libxcrypt'
'setconf'
)
source=('https://collaboration.opengroup.org/pegasus/documents/32572/pegasus-2.14.1.tar.gz'
@@ -25,6 +25,8 @@ source=('https://collaboration.opengroup.org/pegasus/documents/32572/pegasus-2.1
'https://src.fedoraproject.org/rpms/tog-pegasus/raw/main/f/pegasus-2.14.1-build-fixes.patch'
'https://src.fedoraproject.org/rpms/tog-pegasus/raw/main/f/pegasus-2.14.1-ssl-include.patch'
'https://src.fedoraproject.org/rpms/tog-pegasus/raw/main/f/pegasus-2.14.1-openssl-1.1-fix.patch'
+ 'https://src.fedoraproject.org/rpms/tog-pegasus/raw/main/f/pegasus-2.14.1-build-fixes-2.patch'
+ 'Makefile.minimal'
)
sha256sums=('9f2f13a35da218f3cb6e8478246ff7c4d3010560bb4d5de9cbf4272d48e353fb'
'e3924bdb81a4dd2cedfb9c7ba669cb01b32f4c4e16b3af4c06f9a2426a9274d1'
@@ -33,7 +35,10 @@ sha256sums=('9f2f13a35da218f3cb6e8478246ff7c4d3010560bb4d5de9cbf4272d48e353fb'
'5863314f2ff17c32bc340efd5241f809bc1372b8e2fde0b3a2e22c7ab9b64281'
'5de02253442ef8cb3b6f744fa4dd3237b66d96911ab8badd63336a7e1d28a429'
'deb3e52e5406419cc42d15f1a668ed291ef8337217bb5bc9cefd01ef3b804371'
+ '832be374999213a6d940e84c449a7c3566d9dda2b1c2348d7bc601bc907fc228'
+ '7cd222778cc829536ef6fb9c6fb688ac1114f6492cfa61b3881e655c5f38ac96'
)
+options=('debug')
_create_links() {
# create soname links
@@ -55,6 +60,7 @@ prepare() {
patch -p1 -i "${srcdir}/pegasus-2.14.1-build-fixes.patch"
patch -p1 -i "${srcdir}/pegasus-2.14.1-ssl-include.patch"
patch -p1 -i "${srcdir}/pegasus-2.14.1-openssl-1.1-fix.patch"
+ patch -p1 -i "${srcdir}/pegasus-2.14.1-build-fixes-2.patch"
# Fix sqlite and snmp detection
sed 's|lib64/|\$libbase/|g' -i configure
@@ -65,6 +71,8 @@ prepare() {
# add missing z library
sed 's|lcrypt|& -lz|g' -i mak/config-linux.mak
+ # silence deprecation warning (?)
+ sed 's|pthread_yield|sched_yield|g' -i src/Pegasus/Common/Threads.h
}
build() {
@@ -77,11 +85,15 @@ build() {
./configure
- make -f GNUmakefile
+ cp "${srcdir}/Makefile.minimal" Makefile.minimal
+ sed 's|Makefile|Makefile.minimal|g' -i GNUmakefile
+
+ make -f GNUmakefile minimal
}
package() {
- _pegasus_lib=('libpegclient.so.1'
+ _pegasus_lib=(
+ 'libpegclient.so.1'
'libpegcommon.so.1'
'libpegconfig.so.1'
'libpegcql.so.1'
@@ -98,7 +110,7 @@ package() {
'libpegqueryexpression.so.1'
'libpegwql.so.1'
)
- for i in ${_pegasus_lib[@]}; do install -Dm755 "${srcdir}/pegasus/lib/${i}" ${pkgdir}/usr/lib/${i}; done
+ for i in ${_pegasus_lib[@]}; do install -Dm755 "${srcdir}/pegasus/lib/${i}" "${pkgdir}/usr/lib/${i}"; done
# Create soname links
_create_links